Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My first post so bear with me please.My wifes 2006 2.7l v6 Sante Fe Elite has developed a issue that will not occurr long enough or regular enough for mechanics to see the fault,neither does it show up as an error code. And tes it has happened to me.
You start the car and when you drive off it will drop into what i believe is "limp mode"and whilst it will still run you cannot accelerate.Dash warning lights come on and the 4wd icon flashes.Stop car and turn ignition off for a minute andcwhen you start it up all is well except "check engine" symbol stays on.Mechanic hooked the computor checker on to the car with the check engine symbol on and then it goes off and no error codes.? There is no pattern to the fault and no indication when it will happen other than it is always after being parked overnight.You can drive all day with the enhine symbol on,park the car overnight and next day all is ok and check engine is off.
Hope someone had some ideas. I want to sell and get new one but not until this is fixed.
 

·
Registered
Joined
·
3,004 Posts
My first post so bear with me please.My wifes 2006 2.7l v6 Sante Fe Elite has developed a issue that will not occurr long enough or regular enough for mechanics to see the fault,neither does it show up as an error code. And tes it has happened to me.
You start the car and when you drive off it will drop into what i believe is "limp mode"and whilst it will still run you cannot accelerate.Dash warning lights come on and the 4wd icon flashes.Stop car and turn ignition off for a minute andcwhen you start it up all is well except "check engine" symbol stays on.Mechanic hooked the computor checker on to the car with the check engine symbol on and then it goes off and no error codes.? There is no pattern to the fault and no indication when it will happen other than it is always after being parked overnight.You can drive all day with the enhine symbol on,park the car overnight and next day all is ok and check engine is off.
Hope someone had some ideas. I want to sell and get new one but not until this is fixed.
Are you absolutely sure no error codes came on? Are you sure the mechanic didn't just clear them?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
John Thank you for the reply, Both Hyundai and a local service centre say that there are no error codes showing when they look at the car. The first time this happened it was suggested that the throttle sensor on the engine may be faulty however after it was changed with a new one it did not fix it so the original was put back on.
Allan:00000732:
 
1 - 3 of 3 Posts
Top