Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
I purchased a new to me 2016 equus signature. I was looking at the front brakes and have had many factory monoblocks before, but these look slightly different.

First, the pins on monoblock brakes don't have retraining clips, but these do. Looking at replacement pins, this seems normal for this case, but strange.

Second, there is normally a clip that separates the pads in the center held by the pins. It keeps pressure on the outer edge of the pads. On these brakes, I see hardware at the edge that pins are supposed to go through, but it doesn't seem to do anything. I haven't removed them, but they just look like flat pieces with a curl at the outer section for the pins to go through. There is nothing at the center to keep the pads separated. The 4 piston calipers are silver and look coated rather than painted, unlike most factory Brembo or monoblocks. Is this normal?

The reason I asked is because the center area of the pad I removed had lots of dust in the channel. This, again, is the first time I have seen that on monoblock brakes. The center channels are slanted rather than horizontal like brembo pads. I assume these are factory pads because the car has about 30k miles.

Any information is hard to come by on this car and the diagrams I found were very low quality from oem parts stores.

As an aside, I planned on capturing canbus communications through obd2 port since everything is electronic using serial to elm327 with Java or python. The goal is to remote control everything. I don't think the car has electronic steering, but internal buttons, gas, brakes, etc., seem to use canbus. Anyone done this on hyundai before? I wanted to know if there was a uart port. Thought this would be a fun project for an app.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
It looks like it is missing part 58144b. But I don't see the clip I have. It is missing on both sides. But the diagram doesn't show my clips.
 

·
Registered
Joined
·
7 Posts
Discussion Starter #4 (Edited)
Looks like this. I'm painting mine to make cleaning easier right now. They have slight stains that can be seen on close inspection. Paint and clear coat let's the stains wash off.
443647
s-l400.jpg
 

·
Registered
Joined
·
7 Posts
Discussion Starter #5 (Edited)
It does not have the clip used to separate the brakes. This should increase the brake temps since they don't separate. See the brembo brake clips in the center where the pads are removed. In surprised it has frembos instead of brembo.
443648
 
1 - 5 of 5 Posts
Top