Hyundai Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Good day. 2011 Santa fe v6 model. A few weeks ago, the vehicle displayed some off behavior, lights flashing, gauges going crazy etc. Then the car died on the road - dead battery. Got it to an electrician, he changed out the alternator, said that maybe the negative battery cable with the sensor might be bad too, so he left it unplugged (I got a new cable in the interim). For the past couple of weeks, the voltage was fine, light load to heavy load. I picked up a lighter plug voltmeter just to monitor the situation. Couple of nights ago, the car was not charging again at all, voltage was 12V, so we got the car home and parked it. Battery tests ok.

So, the big question: looking at the charging diagram from this forum, what exactly controls the charging of the battery? Just the sensor? Or something else in the PCM? Next step is to clean all the connections and the grounds and ground straps and give it a good wiggle test to see if the problem can be replicated.

Our location is Toronto, so not much salt in the winter but definitely wet-ish.

Thanks for any help.

Ian.
 

·
Registered
Joined
·
1,755 Posts
The regulator is built into the alternator. Could be a few things, bad battery, bad connection to ground. One item... is the alternator grounded ? Had that happen to a Chrysler. There was a strap from alternator to frame that was bad, replaced that with just a big wire and was fine until I sold that car. Also had a bad battery ground wire to a Ford van, internal rust to crushed contact at frame connection, but that as a 20 year old van. Could be bad positive battery wire, internal rust at connection point.

What's the voltage at the battery when car is running ? 14.5 V should be around there. 13V and something is wrong.

Didn't those models fry the brake and other light bulbs, something about bad grounds ? ?
 

·
Registered
Joined
·
1,755 Posts
How about the wires going to the regulator (contacts), and the main wire from Alt to battery (internal corroded) .
How did this person replace the ALT and it is still not working ? ?
 
1 - 4 of 4 Posts
Top