Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
With this warm weather, i put the a/c on and find that it does absolutely nothing.

It's as if i just put it on cool and didn't turn on the a/c. That's how it feels.

Took it to the dealership and they said it's working fine 7 Celsius. and that anything under 10 C is normal for hyundai.

Took it to my buddy's shop and put thermostat in it, it's at about 15C and then eventually after 5 minutes it goes down to 11C. We put the thermostat on a caravan and it was at 3 C.

Took it back to Hyundai a second time, they say its still showing normal. But in the car it's not blowing cold AT ALL!!!!! I'm getting **** off at them.

This **** a/c in the Genesis sucks and they won't fix it because they say it's showing normal.

Has anyone encountered poor a/c in their Genesis and have you done anything to get it fixed?
 

·
Registered
Joined
·
35 Posts
Just for the record the AC in my Azera 3.3 blows freezing cold so usually I keep it at 27C (unless outside is freaking 50C and only then I set it to Lo) and that's in Dubai.

However positive this feedback may be on the other hand I feel a significant drain in power when AC is on - as if I am driving a totally different car! Do you notice loss in power when you switch on your AC?
 

·
Senior Member
Joined
·
1,565 Posts
Take it to another dealer if you can.
 

·
Registered
Joined
·
22 Posts
i was also always questioning if the ac was actually on with the climate control on auto. it felt like i had to push the ac button to get it going but after like a month it just seemed to get better. i have also noticed that it never seems to really crank it until you are going highway speed.

my car also blows hot moist air on the windshield every time the car is started and fogs it up a bunch.
 

·
Registered
Joined
·
6 Posts
QUOTE (Din-Canada @ Jul 19 2010, 03:50 PM) index.php?act=findpost&pid=342970
With this warm weather, i put the a/c on and find that it does absolutely nothing.

It's as if i just put it on cool and didn't turn on the a/c. That's how it feels.

Took it to the dealership and they said it's working fine 7 Celsius. and that anything under 10 C is normal for hyundai.

Took it to my buddy's shop and put thermostat in it, it's at about 15C and then eventually after 5 minutes it goes down to 11C. We put the thermostat on a caravan and it was at 3 C.

Took it back to Hyundai a second time, they say its still showing normal. But in the car it's not blowing cold AT ALL!!!!! I'm getting **** off at them.

This **** a/c in the Genesis sucks and they won't fix it because they say it's showing normal.

Has anyone encountered poor a/c in their Genesis and have you done anything to get it fixed?
Yes Yes Yes
First issue was that the temp sensor on the AC was defective and caused the compressor to stay on always. The condensor?? under the dash would form so much ice that air could not pass through. Symptom was: AC would blow "fine" at first then air flow would stop within 15 minutes.

Once it was "fixed" the AC worked Like a bowl of ice cubes in front of a fan. Meaning it was sub par and barely able to keep the cabin cool. It is now someone elses problem as It was traded in July 2010 for a 2011 Sonata SE. (Luv it)
 
1 - 5 of 5 Posts
Top