Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
2005 Tuscon. The A/C just stopped working. It looks like the compressor clutch is not engaging. I checked what looks like the fuse on the side of the dash and the relay under the hood. I don't have the schematics and was wondering if there are other fuses or switches to look for? I will be going under the hood today to check for voltage at the compressor. If I have voltage at the clutch and it's not engaging that would mean a bad compressor, right?
I don't know if this is related or not, but I discoverd this problem after one day when the battery went dead for no apparent reason. Battery one year old, charged and now is fine.

Thanks
Barry
 

·
Registered
Joined
·
4,851 Posts
It could mean your refrigerant has leaked out someplace, since the compressor won't come on if there's no pressure in the system. A lot of times a stone put a hole in the condenser and the springs a leak.
 

·
Registered
Joined
·
17,552 Posts
Need sufficient R-134 to trip the pressure switch which is input to PCM, which in turn fires the relay, and the relay completes power circuit to field coil.. Look for a 10A fuse in the engine compartment fuse block marked AC I think...

You can look at data stream on GDS and see the inputs to PCM and PCM output to relay..

Have seen a couple wire issue between block and field coil, and a field coil that was indeed open circuit, and a few connector issue at field coil..
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top