Hyundai Forums banner
1 - 5 of 5 Posts

· Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
I got my RB from a family friend a few months back. I went to the dealership the other day and the manager stated that my battery needed replacement as it was out of warranty by 4 months (24 month warranty) and would roughly cost me $200 USD. I went to a private shop and found that it holds 10.8V but can still start the car fine and no lights on the cluster. The master tech said it was fine and that my charge system functions good. Now onto my Question, Has anyone used an Odyssey Battery or any other AGM type battery? If so are there modifications that would i have to do to make it fit such as trimming the battery tabs.

The Odyssey Battery model Im looking to replace it with is the PC1200MJT

Thanks
 

· Registered
Joined
·
36 Posts
Discussion Starter · #4 ·
Any ther recomendations besides the pc1200MJT? Would i need post adaptors to make it work? I really dont want a regular battery that would just die here due to the weather.

I tried optima in my truck and wasnt pleased. It died after a year. Currently running a group 34 odyssey for the past 8 months starts great.


Sent from AutoGuide.com Free App
 

· Registered
Joined
·
36 Posts
Discussion Starter · #6 ·
Is it the hot weather that kills them? Here, the first cold snap weeds out the weak ones.
AFAIK heat kills batteries more than cold weather, although a battery in a colder climate would have more strain starting the engine.

BTW any info on how many volts does the Alternator charge the battery? Was it 13.2V or 14V? Load dependent? Couldn't really see the needle on the battery checker dealie at idle.
 

· Registered
Joined
·
36 Posts
Discussion Starter · #9 ·
The RB shop manual says 14.55 volts (+/- 0.3 volts).. I've never checked mine, but whenever I diagnose a charging system, I look for around 14.2 volts...
Thanks for the info. Im still deciding on getting the odyssey battery. Will try to order one and make it fit.
 

· Registered
Joined
·
36 Posts
Discussion Starter · #11 ·
Its been awhile since I updated the post. Well I ordered and installed the PC1200 and it fits without any issues. I was even able to use the same mounting hardware and factory cover. Measured voltage was 13.28 with all accesories on.


Sent from AutoGuide.com Free App
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top