Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
My 2017 Hyundai Accent turned off while driving. I was travelling 40 mph,
level road at 4:32 pm. I had a half tank of fuel and haven't refueled in a
week. I have 20,000 on the vehicle. The speedometer and tach needles
dropped to zero, all of the dash lights came on and, really weird both of the
trip meters went to zero. While still moving it restarted and I continued. It
concerns me that my car would just shut off without notice.
 

·
Registered
Joined
·
13,011 Posts
Cranks sensor wouldn't effect the speedo or trip meters. Sounds more like a problem with one of the main power supplies or grounds to me. And I wouldn't expect the grounds to be bad on a 2017 model.

I assume a 2017 is still under warranty? Not that it will do you much good if the fault is intermittent. The dealer probably wont do anything unless the fault cooperates and happens while the dealer tech is test driving it.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
Cranks sensor wouldn't effect the speedo or trip meters. Sounds more like a problem with one of the main power supplies or grounds to me. And I wouldn't expect the grounds to be bad on a 2017 model.

I assume a 2017 is still under warranty? Not that it will do you much good if the fault is intermittent. The dealer probably wont do anything unless the fault cooperates and happens while the dealer tech is test driving it.
Cranks sensor wouldn't effect the speedo or trip meters. Sounds more like a problem with one of the main power supplies or grounds to me. And I wouldn't expect the grounds to be bad on a 2017 model.

I assume a 2017 is still under warranty? Not that it will do you much good if the fault is intermittent. The dealer probably wont do anything unless the fault cooperates and happens while the dealer tech is test driving it.
Thank you
 

·
Registered
Joined
·
1,919 Posts
Does it have an after-market remote start wired into it?
 

·
Registered
Joined
·
4 Posts
I had that issue in my 2009 accent yesterday while at a stoplight. Now it’s normal with the dash lights showing TPMS, Airbag, and Engine (haven’t had it scanned yet for trouble codes) when I accelerate and then my RPM and Speedometer get frozen. Will check fuse box when daylight breaks.


Sent from my iPhone using Tapatalk
 
1 - 7 of 7 Posts
Top