Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
Hi Guys
Recently i got few problems with my car.

All of a sudden it started misfire and come up with terrible noises. and i scanned for the codes and i have attatched them below.


Can you please help me with this?
i recently replaced the MAF , And did a full engine service after those errors. still the fault is there.

exhaust sounds bad, not smooth i can feel the misfire sound in the exhaust.
 

Attachments

·
Banned
Joined
·
7,039 Posts
What MAF was bought and when? Unplug the MAF and see if it runs OK.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #3
What MAF was bought and when? Unplug the MAF and see if it runs OK.
What MAF was bought and when? Bought it few months back. Got it from Ebay

Even when i remove the MAF cable its the same. So i think its not the MAF, right?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Hello,
You SHOULD check your ingition coil, located at the right side of your engine. The manual I post is from a 2002 G4EA 1.3 engine. If that's not your engine, let me know.
This is my engine.
I assume there must be a vacuum leak.
Or you suggest me to replace the coil and check?
 

·
Registered
Joined
·
3 Posts
Before you start replacing things, check the coil to see if the values are within the manufacturer's specs. You just need a multimeter to do this.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Before you start replacing things, check the coil to see if the values are within the manufacturer's specs. You just need a multimeter to do this.
Thank you. I will do for sure. I have a multi-meter.

Thank you very much. I will update you.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #8
Hi Guys,

Last week the car was running fine, no problem with it, no noise, no misfires.

But again it started yesterday. Its weird it was parked for few days and it worked fine last week and all of sudden it was giving the same faults again.
 
1 - 8 of 8 Posts
Top