Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 1998 Accent 1.3 which developed an annoying misfire while driving.
Initially it was quite subtle but has has now increased significantly.
The car seems to have no power and driving it has become a real chore.
The fuel consumption has rocketed on average about 12-15mpg!!

There is an oil burning smell when the car warms up and now since the consumption increase there is also a smell of petrol when starting and occasionally while driving.

I have changed the plugs and HT leads to no effect.
When I changed the plugs, number 3 was covered in oil.

Had a compression test done and compression is fine across all 4.

There is also a constant hissing noise like air escaping but I am unable to locate the source.
Hissing decreases on acceleration but is constant at idle.

My knowledge of car mechanics is quite limited and the information supplied above is as mentioned by a friend who looked at the car for me. Due to his work commitments he was unable to investigate further.

Any suggestions, advice etc would be greatly appreciated.

Sam
 

·
Registered
Joined
·
3,151 Posts
check ECU codes first....guessing a sensor such as the MAP sensor here. the oil could be unrelated, but don't rule it out. check the PCV valve to see if its clogged or stuck open. i think its around cyl. 3 where it goes into the intake...not 100% sure there.
 

·
Registered
Joined
·
39 Posts
Have you checked the plugs that connect to the spark plug cables in the ignition coil itself? Is there any oxidized dust in any of the chambers. It would look like a white/green dusty compound. Also, have you checked the timing belt?
 
1 - 3 of 3 Posts
Top