Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi Guys

I wonder if someone can help me.

I have a 2011 Elantra 1.6 GLS.

I recently picked up an issue with my car. Please bare with me as Im not sure if I can explain this correctly :)

When I accelerate and get to around 3.5 - 4 RPM the car like kicks in and gets more power (as if a small turbo kicked in kinda feel or maybe a misfire at that RPM). What could be the problem here?

I recently had a guy test with a code reader and it displayed Cam Shaft Sensor which I have changed. I also put new spark plugs and a battery but the feeling is still there.
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,318 Posts
It might help us if you posted the actual trouble code that was logged?
Have you checked to see if the code has been logged again since you replaced the sensor?
 

·
Registered
Joined
·
1,606 Posts
When I accelerate and get to around 3.5 - 4 RPM the car like kicks in and gets more power (as if a small turbo kicked in kinda feel or maybe a misfire at that RPM). What could be the problem here?

I recently had a guy test with a code reader and it displayed Cam Shaft Sensor which I have changed. I also put new spark plugs and a battery but the feeling is still there.

The intake has two sets of runners - long for low end torque and shorter for high rpm power. There is a flap that opens at around 3500 to allow the short ram tubes to feed more air into the engine. What you're feeling is that surge of power when the flap opens. As engine speed drops, the flap closes again for more torque at the lower rpm.
 
1 - 4 of 4 Posts
Top