Hyundai Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
505 Posts
Discussion Starter · #1 ·
less than 60K...I assume it is covered...

Anyone else have an AC issue.

Blower blows as usual, just warm air...assume low on freon which means there is a leak..
 

·
Registered
Joined
·
3,712 Posts
Components probably are but I know refrigerant isn't. You might want to scan the warranty card pinned here somewhere. Seems I read something about A/C 3/36. Not sure.

5/60 defective parts no R134A
 

·
Registered
Joined
·
505 Posts
Discussion Starter · #4 ·
Hmmm.

Seems odd, that is a part (fitting, hose etc) fails and causes the freon to leak, the part is covered, but not the freon...

Will know on Tuesday one way or the other..
 

·
Registered
Joined
·
215 Posts
Well, glad it was just a fuse!
 

·
Registered
Joined
·
505 Posts
Discussion Starter · #7 ·
A/C went out again yesterday...assume another blown fuse.

Dropped off at dealer this AM....should be interesting since everything 'checked out' on Tuesday after they replaced the fuse. :w00t:
 

·
Registered
Joined
·
505 Posts
Discussion Starter · #8 ·
Just heard from dealer...

They replaced the 'Field Coil' and the clutch for the compressor..

We'll see how this goes!
 

·
Registered
Joined
·
17,552 Posts
QUOTE (Klute @ Aug 19 2010, 03:37 PM) index.php?act=findpost&pid=350513
Just heard from dealer...

They replaced the 'Field Coil' and the clutch for the compressor..
Should be good to go with new coil.... old coil likely have too much current draw and pop the fuse after it all heat up.. then wonder if they had to cut connector off at either the engine harness or at coil pigtail,,,, as MOBIS been packing corrent field coils with wrong connector that dont match engine harness.... Been through that 2 times myself in last month... first 1 was obviously replaced before, somebody did a hack job wire splice, any wonder it not corrode from exposure..

We'll see how this goes!
 
1 - 9 of 9 Posts
Top