Hyundai Forums banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So I have a '10 Genesis coupe and my AC hasn't been working for a year now. I originally took my car in last summer when I noticed it wasn't cooling the air at all... pretty much the air blowing was the same temperature with the AC on and off. So I took it to a dealer and they said I had zero freon. They refilled it and put a dye in. Then about a month later I took it to a different dealer closer to school and told them the situation and about the dye. They still couldn't find the leak... and it was empty again. So the second dealer refilled it again and put more dye in. Month later I take it back and they still don't find the leak... no freon again. So I take it to my own shop (that I trust and have been going to for 15+ years.. also know the owners). they found the leak right away by looking for the dye. They said the leak was in the expansion valve/evap line (I think I forgot the second area, I just remember the expansion valve). The shop's exact words were that there was so much dye it was impossible to miss and now it needed to be cleaned up because there was so much dye. So I ask a friend and he recommends a third dealer. I go and explain the situation, and also what my own shop said. Guess what? they can't find it. So they recharge it put dye in and this happens two more times. Finally they "find" a leak in some hosing. They replace the hosing but then they realize the expansion valve wasn't working properly. So they replace the valve and assure me 100 times it was fixed. Ac blew nice and cold and a couple months later..'doesn't work again. I'm taking it to the dealer tmrw but I know they won't find anything.

Also forgot to mention, after the first two visits to the third dealer, I called corporate... well not corporate because I can't find the number for corporate. I talk to a customer service rep who will not let me talk to her manager at all. She tells me to give the dealer one more chance, whic I did. what I'm thinking now is that since the dealer fixed it and it still doesn't work, I should be allowed to take it to my own shop and get reimbursed. doubt that'll happen.

Any suggestions guys? I'm thinking maybe I might need a lawyer soon..
 
1 - 1 of 1 Posts
Top