Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
The ABS warning lamp is on.
I tried a diagnostic tool, which reports these 2 errors as shown in the attached picture.


Both relays in the little box by the ABS-pump have been tested, with load, and found OK.
All 4 wheel-sensors have been disconnected and measured, and is OK.
The ABS rings on the wheel hubs are all whole and clean.
The ABS-pump has been jump-wired, and is spinning up as normal.

I'm a little out of ideas right now.
Can anyone point me in any direction about where to look?
 

Attachments

·
Registered
Joined
·
12,681 Posts
All 4 wheel-sensors have been disconnected and measured, and is OK.
The sensors were measured how?

If the sensor itself is OK the fault must be else where in the circuit. I'd suggest checking the wiring between the right rear sensor and the control module. Check both the continuity of the wires and for resistance to ground. When testing the wiring the sensor and the module should be disconnected.

Johan Gjelberg said:
Both relays in the little box by the ABS-pump have been tested, with load, and found OK.
Again, the relays themselves are OK so the fault is elsewhere in the circuit.

Johan Gjelberg said:
The ABS-pump has been jump-wired, and is spinning up as normal.
I assume you just bridged the relay load circuit terminals on the relay socket?
If so you know the relay load circuit is OK, so the fault is likely on the relay control circuit (the relay coil power supply & ground). You'd need to check the wiring between the relay coil terminals on the relay socket and the ABS control module.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3 (Edited)
The sensors are just a coil with a magnetic core. They work just like the pickup on an electric guitar.
There is no load on them, so there is either connection or an open circuit.
The resistance of all sensors are ca 1000 Ohms, so I am pretty sure they are OK.
Ground connection for the relays is checked and also found OK.

Where is the ABS module located?
 

·
Registered
Joined
·
12,681 Posts
Ground connection for the relays is checked and also found OK.
The relay coil is grounded because the ABS warning light is on. The terminal with the ground would have +12V if there wasn't a fault and the warning light was off.
It's the wire on the other side of the coil you need to check. The one that links the relay coil to the ABS module.

Johan Gjelberg said:
Where is the ABS module located?
I don't know off the top of my head. When I get to work tomorrow I'll see if I have any info on the circuit I can share with you.
 
1 - 6 of 6 Posts
Top