Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
just purchased a 2004 XG350L and it seems to be a great car. I have one small problem though. I cannot seem to get any air through the vents at the back part of the center console after depressing the rear ventilator switch (located to the right in the climate control cluster). I have tried all modes of airflow and rotated the air flow control knob for these rear vents --- all to no avail. I called the dealer but he just said "it should come on but don't expect much air out of there". I feel just about nothing at all.
Does anyone have any suggestions about how to get that rear air flowing?
 

·
Registered
Joined
·
1 Posts
hi Allen.......
I have the same car and I can feel air blowing out of the rear vent, it is not a strong as the front vents but it does do the job. If you feel nothing I think you should bring the car in for repair.
bye

Originally posted by Allen@Jul 14 2004, 09:34 AM
just purchased a 2004 XG350L and it seems to be a great car. I have one small problem though.  I cannot seem to get any air through the vents at the back part of the center console after depressing the rear ventilator switch (located to the right in the climate control cluster). I have tried all modes of airflow and rotated the air flow control knob for these rear vents --- all to no avail. I called the dealer but he just said "it should come on but don't expect much air out of there". I feel just about nothing at all.
Does anyone have any suggestions about how to get that rear air flowing?
[snapback]92[/snapback]​
 

·
Registered
Joined
·
6 Posts
I suggest to put stronger blower position, and shut/reduce the air flow in each individual front air outlet. I have done this and we got reasonable air flow in rear outlet.

Originally posted by Allen@Jul 14 2004, 02:34 AM
just purchased a 2004 XG350L and it seems to be a great car. I have one small problem though.  I cannot seem to get any air through the vents at the back part of the center console after depressing the rear ventilator switch (located to the right in the climate control cluster). I have tried all modes of airflow and rotated the air flow control knob for these rear vents --- all to no avail. I called the dealer but he just said "it should come on but don't expect much air out of there". I feel just about nothing at all.
Does anyone have any suggestions about how to get that rear air flowing?
[snapback]92[/snapback]​
 

·
Registered
Joined
·
52 Posts
I think the air flow hose is not connected and you can check that by opening the middle armsit and pull the cassete box(the one with the mobile power outlet) outside then see the hosts ...

also toch it and check if it is loose or not...


thanks...MMK
 
1 - 4 of 4 Posts
Top