Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
29 Posts
Discussion Starter #1 (Edited)
Hi!

I have a couple of issues that are bothering me with my Hyundai santa fe 2.4L - 02 (manual, EU model). No major issues just small stuff, i'll list them below.

1.(edit: ignore this one) Shows wrong speed. The gauge shows me going anywhere from 5 to 15 km/h faster than actual speed. The error is bigger the faster I go. Havent showed right speed under the time I have owned it, it has 235/60R16 tires.

2. Remote unlock/lock works intermittently. When I use key fob to unlock/lock it seems to work randomly. If I unlock with key when remote doesnt work the alarm doesnt go on. If I unlock with key when remote does work the alarm goes on. I've changed battery, so dont know what to do now.

3. O2 sensor error code. Bank 1 sensor 1 is faulty from nowhere. Is this a usual error with some other fault behind it or do I need to replace o2 sensor?

4. It's sluggish, and have been all the time during time ive owned it. For example, flooring the gas pedal when going up a small incline or at highway speeds, you can barely feel it accelerating. And going from 80 km/h to 110 km/h in 5th gear takes longer than it should and usually I need to gear down so traffic behind me doesnt honk.

5. Rear wiper doesnt work. Got a replacement from the scrapyard, including a control module and it still doesnt work. My old wiper motor was seized where you attach the wiper blade. But "new" one is free to move but still doesnt.

So these are my issues. Any help in solving them is greatly appreciated!
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
14,552 Posts
1. Shows wrong speed. The gauge shows me going anywhere from 5 to 15 km/h faster than actual speed. The error is bigger the faster I go. Havent showed right speed under the time I have owned it, it has 235/60R16 tires.
That's normal. All cars do that by design. They are designed that way so when you get pulled for speeding you can't blame the car manufacturer.

ML96 said:
2. I've changed battery, so dont know what to do now.
Does the remote have a light on it that comes on when you press the buttons. When the car doesn't react to the button press is the light illuminating?
Do you own more than one remote? Are both doing the same thing?

ML96 said:
3. O2 sensor error code. Bank 1 sensor 1 is faulty from nowhere. Is this a usual error with some other fault behind it or do I need to replace o2 sensor?
First of all, an O2 code doesn't mean the B1S1 is faulty. It just means the engine ECU isn't happy with the sensor signal for some reason. It's impossible to say whether you need to replace the sensor or if the code is just a symptom of some other issue. Maybe if you tell us what the code was we'd be able to take a more educated guess.

ML96 said:
4. It's sluggish, and have been all the time during time ive owned it. For example, flooring the gas pedal when going up a small incline or at highway speeds, you can barely feel it accelerating. And going from 80 km/h to 110 km/h in 5th gear takes longer than it should and usually I need to gear down so traffic behind me doesnt honk.
LOL...other driver honk at you for driving at 80km/h. My reaction to that would be to slow down, not drop a gear to speed up.
Sorry, I'm not familiar enough with the car/engine combo to comment on how it should perform.

ML96 said:
5. Rear wiper doesnt work. My old wiper motor was seized
If the original motor was seized could that maybe over loaded the circuit and caused the fuse to blow? I assume you have tried replacing the fuse?

If I helped you fix it, why not...

Your support is greatly appreciated
 

·
Registered
Joined
·
29 Posts
Discussion Starter #4 (Edited)
That's normal. All cars do that by design. They are designed that way so when you get pulled for speeding you can't blame the car manufacturer.
Oh okay, never had any car that shows that much different from actual speed. Cause since I started driving this car and follow speed limit everyone wants to overtake me, when i go 130 according to my car im actually going like 110 which is the speed limit on the highway. So feels like something is wrong when every single car drives faster than me.

Does the remote have a light on it that comes on when you press the buttons. When the car doesn't react to the button press is the light illuminating?
Do you own more than one remote? Are both doing the same thing?
It has a light, and it illuminates whenever I press a button regardless of if the car unlock/locks or not. Only have one remote.
Edit: thought of another thing that is weird, sometimes when unlock doesnt work, I can press on lock and see turn signals blink and then press unlock and then it works. But sometimes nothing happens and thats when I need to unlock with key.

First of all, an O2 code doesn't mean the B1S1 is faulty. It just means the engine ECU isn't happy with the sensor signal for some reason. It's impossible to say whether you need to replace the sensor or if the code is just a symptom of some other issue. Maybe if you tell us what the code was we'd be able to take a more educated guess.
I think the code was P0135. And it showed o2 sensor bank 1 sensor 1 faulty.

LOL...other driver honk at you for driving at 80km/h. My reaction to that would be to slow down, not drop a gear to speed up.
Sorry, I'm not familiar enough with the car/engine combo to comment on how it should perform.
Well when going from 80km/h speed limit to 110 km/h speed limit people tend to wanna reach the speed limit fast. But my Hyundai just doesnt seem to have any power on lower rpms. In steep hills i usually have to have it in first gear to avoid downshifting near the top.

If the original motor was seized could that maybe over loaded the circuit and caused the fuse to blow? I assume you have tried replacing the fuse?
Fuses are all fine, tried hooking up + and - from battery to the cable coming from the motor but nothing happened. Dont know if I hooked up wrong or if it needs some other input to work.
 

·
Registered
Joined
·
1 Posts
Pick one. Doing more than one at a time is convoluted.
In response to the speedometer issue, I own the same vehicle with the same size tires on it. Recently discovered that the recommended size is 235/70R16. By downsizing the tires to 235/60R16, the speedometer will be off by 5 or more km/ph depending on your speed. I compensate by driving 5 over and stay with traffic. Also, your odometer will be slightly higher than actual mileage, but not significantly. Check the label on the door frame for the correct tire size. The larger tires cost more and the vehicle drives fine with the smaller size, so probably the reason for the change.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #6
In response to the speedometer issue, I own the same vehicle with the same size tires on it. Recently discovered that the recommended size is 235/70R16. By downsizing the tires to 235/60R16, the speedometer will be off by 5 or more km/ph depending on your speed. I compensate by driving 5 over and stay with traffic. Also, your odometer will be slightly higher than actual mileage, but not significantly. Check the label on the door frame for the correct tire size. The larger tires cost more and the vehicle drives fine with the smaller size, so probably the reason for the change.
Yeah, it might be the tires that is causing the issue, but have never had that problem with any car before. Just feels so weird when going 130 on a 110 road and every car wants to overtake me. So that must mean im actually going slow. And I thought that tire size couldnt be the cause for such a large missreading.
 

·
Registered
Joined
·
6,775 Posts
Just feels so weird when going 130 on a 110 road and every car wants to overtake me. So that must mean im actually going slow.
It just means you're going slower than them, not the speed limit.
 

·
Registered
Joined
·
29 Posts
Discussion Starter #8
It just means you're going slower than them, not the speed limit.
Yes ofcourse people drive faster than the speed limit, but according to my gps im going basically the speed limit when my car shows 20 km/h over (tested today). And the reason this annoys me is that we have speeding cameras here set to the speed limit, and not being sure about my speed when going past them without slowing down traffic too much is annoying.

But if you guys say its the tires ill drop this issue and get back to it once I switch tires.
 
1 - 8 of 8 Posts
Top