Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Here is my situation and am hoping I might get somebody who can actually help me with this. I have a 99 hyundai accent automatic with transmission issues. I bought the car with the idea it had a blown transmission. The reason I thought there was problems was because it would not go into reverse and it was hard shifting through second and third gear. I went ahead and did a complete replacement on the transmission and I am still having the same problems. I am thinking that this is an electrical or pressure with the pump. There's no hesitation when going into drive. I put the car into reverse and gave it almost 2 min. to engage with no results. Is there an electrical or other solenoid issue that would prevent this car from engaging into reverse. Transmission fluid levels are good. I know a lot of other people out at the same problem with this vehicle, and would really like some help solving this problem
 

·
Registered
Joined
·
39 Posts
I'm not familiar with this transmission but being an automatic would be similar to other brands.
Firstly, have you made sure the selector cable is properly adjusted?
This sis usually checked and done by placing the selector in neutral, then from under car or by the side of trans, disconect the cable from the trans. and makes ure the trans is in neutral, then check that the connectro lines up.
Not sure if this model has a gearbox ECM but check all connectors and i think there is an inhibitor switch below centre console.
Ther arte a coup,e of good manuals available...Haynes comes to mind, they are cheap....get one!
 

·
Registered
Joined
·
7 Posts
Hi do a fault code check and see if that any codes come up. If not do a computer reset and see how that goes .This forum is great for info so have a browse and good luck i hope you no serious issues and its a cheap fix
Cheers Darren
 
1 - 3 of 3 Posts
Top