Hyundai Forums banner
1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hi, just bought my 98 Lantra GL 1.6
has been running awsum, but started to fail to restart after short stops (ie, visit friends, shop) when it did go again went great, then started to develope a random miss. yesterday it cut out on me at a stop sign, it restarted but now has a bad miss, that shakes the car! the miss continues even when excelarated
this has been over the space of around 10days
it has had new spark plugs 3weeks ago
 

·
Registered
Joined
·
386 Posts
Hello flyinkiwi

You say the plugs have been changed.

I'll assume that they were properly set to the correct gap( 1.0 - 1.1 mm, I believe).

Were the leads changed? Do you know their history? It's quite OK for them to run the engine under no load but to falter and fail when driving. Check them as well.

Have you washed the engine and let water into the coil or other electricals?

If your leads are fine and fuel is coming through OK, then consider your coil.

You might also consider reseting the ecu by removing the fuse from the underbonnet fuse box for a few minutes. Bring the car to operating temperature first, stop the car, remove the fuse. Leave for a couple of minutes then refit, start the car and leave idling for 3-4 minutes to reset computer to factory defaults.

Hopefully it's something simple like your leads.

Cheers,

Andrew
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #5 ·
Hi Andrew, Thanks for your thoughts

ok so, yes spark plugs were all set correct, ect
no i havent done the leads, alto this is somthing i am doing today
havnt washed or had xcess water over the engine
i will be looking at coil for sure
did a reset of ecu this morning, and interesting the car started up and run like a champ, no miss, sounded sweet, i run till was up to temp and turned it off let it rest and restarted, away she went first time. i repeated 3times, then happy it seemed ok went for a test drive. car went great for the first couple of minutes, then had a couple of misses, and then only a few hundred yards later just cut out. ive had a few goes at restarting it, but is not firing up :(

back to it, thanks :thumbsup:
 

·
Registered
Joined
·
4 Posts
Discussion Starter · #6 ·
FUEL PUMP!

if you get stuck like this, a trick i learnt today, is: get sumone to bang on the fuel tank while you turn it over, the car will start up very quickly. also it is most noticable on a lower tank of gas than a full tank.

thanks for your posts, they hav been very helpful :thumbsup:
 
1 - 6 of 6 Posts
Top