Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
Hi,

98 excel dohc.

My alternator has stopped working.

I am trying to figure out if it is a missing lead/wire or the alternator itself is faulty.

I noticed that there is a square plug receptacle on TOPSIDE rightish end of the alternator (when looking down from above, just left of the oil dipstick, ontop of that little steel flap that can flap on a hinge upward to the right, on the alternator), but no lead is plugged into the receptacle. (the picture attached is to show the "view angle,general location").


plug is here in this dark area ontop right of alternator,,

Should there be a wire plugged in there, and if so, what does it attach to at the other end.
(obviously, my electrics knowledge is not great !!).

TY
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #2 ·
clearer picture with receptacle shown

Hi,

Got a bit of light in there.
It is that squarish socket between the blue and white label and the reddish rusty bolt.
 

·
Registered
Joined
·
133 Posts
Funnyfred345, could be the alternator brushes that are worn out, do you have pick-a-part in Australia? help yourself parts, maybe best to replace it with a second hand one, if the diode pack has blowen there is not much you can do anyway...just make sure to disconnect the battery before you remove the part...there should be one large cable and perhapes a couple of small ones (look for a connector plug)
 
1 - 3 of 3 Posts
Top