Hyundai Forums banner

21 - 37 of 37 Posts

Registered
Joined
11 Posts
Thanks so much guys! lavr, is the the USB assembly you linked above the entire box, including the AUX port (see attachment)? Or just the female-to-male connection into the stereo that I'd need to custom fit into that piece?
 

Attachments

Registered
Joined
11 Posts
For your android auto or car play there is a separate 4 pin plug at the back of the radio this can be got on ebay but still it won't work til we can make know the car is running and in park to even set it up.

***
I haven't noticed the "Battery Discharge Warning" light come on the last few times I've driven. I wonder if the HU just needed some time on with the car to recognize the power was on? :blink:
 

Registered
Joined
122 Posts
Discussion Starter #24
I haven't noticed the "Battery Discharge Warning" light come on the last few times I've driven. I wonder if the HU just needed some time on with the car to recognize the power was on? :blink:
Does your android auto work? does the clock?
 

Registered
Joined
11 Posts
Does your android auto work? does the clock?
USB port isn't recognized with a flash drive inserted--I assume this means Apple CarPlay (or Android Auto) won't work when I connect to my iPhone, but admittedly I haven't tried.

Clock does not work. Don't even know where to begin with that one.
 

Registered
Joined
122 Posts
Discussion Starter #26
So I have a Metra -71-7306 OEM radio plug harness and this gives me every wire I need for the 7" Stereo. But I still need the 2019 5" Stereo and A and B Plug diagram to be able to correctly identify the wires in the A and B plugs in the 2019 SE.
 

Registered
Joined
122 Posts
Discussion Starter #27
USB port isn't recognized with a flash drive inserted--I assume this means Apple CarPlay (or Android Auto) won't work when I connect to my iPhone, but admittedly I haven't tried.

Clock does not work. Don't even know where to begin with that one.
The plug you see by your auxiliary power ports won't work for android auto you need the cable that connects to the 4-pin plug on the back of the stereo its the plug beside the blue gps antenna connector.
 

Registered
Joined
35 Posts
Thanks so much guys! lavr, is the the USB assembly you linked above the entire box, including the AUX port (see attachment)?
Exsectly chris_.
But this box have two variant.
First, with one connector for USB & AUX. Second, with two connectors, separately for USB and AUX.
 

Attachments

Registered
Joined
35 Posts
When I installed 7"HU, I have the same problems with warning, with no working rear camera, with clock (still have). But, first I install new USB cable and new USB box for work AA, because it was main target for using 7"HU. And Android Auto working very good, with problems with warning, rear camera and clock.

In this time I have only problem with clock, and I will try to use external GPS antenna, for trail.
 

Registered
Joined
11 Posts
When I installed 7"HU, I have the same problems with warning, with no working rear camera, with clock (still have). But, first I install new USB cable and new USB box for work AA, because it was main target for using 7"HU. And Android Auto working very good, with problems with warning, rear camera and clock.

In this time I have only problem with clock, and I will try to use external GPS antenna, for trail.
Got the correct USB cable and SDARS antenna for XM per the links in this thread, so I'm halfway home. Thanks everyone. Wondering about simply taking the SE to a car audio / accessories shop in town and asking them to help me rewire for the backup camera while installing a new amplifier, DSP, and subwoofer. Also figure out a way to hide the XM radio antenna and maybe snake the USB cable into the glove box while they're at it...

Anyway, thanks again for your help!
 

Registered
Joined
122 Posts
Discussion Starter #33
Got the correct USB cable and SDARS antenna for XM per the links in this thread, so I'm halfway home. Thanks everyone. Wondering about simply taking the SE to a car audio / accessories shop in town and asking them to help me rewire for the backup camera while installing a new amplifier, DSP, and subwoofer. Also figure out a way to hide the XM radio antenna and maybe snake the USB cable into the glove box while they're at it...

Anyway, thanks again for your help!
If you do this please let us know how it turns out.
 

Registered
Joined
5 Posts
tc0566, thanks for starting this thread. I purchased a 2019 VE 7" OEM radio to replace the 5" OEM radio in my 2019 SE.

After installation, I have the same results as you:
(1) the steering controls work;
(2) the radio works; and
(3) Bluetooth works.

However, the date and time are unavailable to set, and the backup camera does not activate. In addition to the issues you've identified, the new HU does not recognize my USB stick (a problem that extends to Apple CarPlay I imagine), and I get a "Battery Discharge Warning" even though the car is fully powered on.

(I also am not sure what adapters I need to get an XM antenna hooked in, but that's a problem I'd love to get to eventually.)

I suspect I'll need to move some wires around in Connectors A and/or B. Thanks lavr for sharing those diagrams you have. I'll do some more digging and let everyone here know if I find something helpful.
Can you share the part number of the 2019 VE 7" OEM radio? Thanks.
 
21 - 37 of 37 Posts
Top