Hyundai Forums banner

1 - 20 of 37 Posts

·
Registered
Joined
·
123 Posts
Discussion Starter #1 (Edited)
7" OEM Touchscreen install to 2019 SE Issues

Installing a 7" inch OEM stereo from a 2018 SEL into my 2019 SE. Can't get stereo to recognize that the car is powered on. The radio is working but camera won't work, time date settings grayed out and says to power on car. Radio will work.. Just no camera and can't set time. Wondering if could be the c plug my car does not have it and both a and b plug have more wires in my 2019 than the 2018 had. My car came factory with a 5" touchscreen and back up camera.
 

·
Registered
Joined
·
122 Posts
Installing a 7" inch OEM stereo from a 2018 SEL into my 2019 SE. Can't get stereo to recognize that the car is powered on. The radio is working but camera won't work, time date settings grayed out and says to power on car. Radio will work.. Just no camera and can't set time. Wondering if could be the c plug my car does not have it and both a and b plug have more wires in my 2019 than the 2018 had. My car came factory with a 5" touchscreen and back up camera.
You're probably going to have to do quite a bit of rewiring to get everything to work. I'm not entirely sure if anybody here has done this before.

I did something similar with an old Nissan Versa I owned -- took a stereo out of the SV "special edition". Some of the wheel mounted audio controls didn't work, the bluetooth microphone didn't work and the backup camera didn't work because mine didn't even come with any camera. I was able to get the steering wheel controls to work, but I never got the microphone to work.

If you can find any sort of wiring diagrams for both stereos, that should help you figure out what needs to be done.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #3
You're probably going to have to do quite a bit of rewiring to get everything to work. I'm not entirely sure if anybody here has done this before.

I did something similar with an old Nissan Versa I owned -- took a stereo out of the SV "special edition". Some of the wheel mounted audio controls didn't work, the bluetooth microphone didn't work and the backup camera didn't work because mine didn't even come with any camera. I was able to get the steering wheel controls to work, but I never got the microphone to work.

If you can find any sort of wiring diagrams for both stereos, that should help you figure out what needs to be done.
steering wheel controls all work even bluetooth, just doesn't detect that car is powered on
 

·
Registered
Joined
·
123 Posts
Discussion Starter #6 (Edited)
This is the one I've seen. I hope it works for you.
It's a PDF and I think you can't download it using the mobile version, only on a desktop.
I have that it does not cover the 2019 5"touchscreen. The 2019 5" touchscreen has the same A and B plugs as the 2017 7" but the plugs have more wires and it does not have the C plug. I need the diagram specifically for the 2019 5" touchscreen.
 

·
Registered
Joined
·
35 Posts
Installing a 7" inch OEM stereo from a 2018 SEL into my 2019 SE. Can't get stereo to recognize that the car is powered on. The radio is working but camera won't work, time date settings grayed out and says to power on car. Radio will work.. Just no camera and can't set time. Wondering if could be the c plug my car does not have it and both a and b plug have more wires in my 2019 than the 2018 had. My car came factory with a 5" touchscreen and back up camera.
For start rear camera work, you have to plug pink wire (pin #33) in connector M09-CB on the fuse F23 10 amp (5 module).
 

·
Registered
Joined
·
123 Posts
Discussion Starter #8 (Edited)
For start rear camera work, you have to plug pink wire (pin #33) in connector M09-CB on the fuse F23 10 amp (5 module).
Do you have a diagram or pics? The 2017 7 inch stereo is IGN1 at pin 33 of connector B and yes it was connected to power with key on...but in the 2019 the plug doesn't have this wire at pin 33 that is why I need a diagram for the 2019 5 inch screen.
 

·
Registered
Joined
·
35 Posts
Unfortunately, I don't have a wiring diagram 5" radio on Elantra MY'19.
I have an only wiring diagram 7" radio on Elantra MY'17. And I found 5" radio wiring diagram on the Russian language.
I think this wiring diagram from Elantra MY'17 too.
 

Attachments

·
Registered
Joined
·
11 Posts
tc0566, thanks for starting this thread. I purchased a 2019 VE 7" OEM radio to replace the 5" OEM radio in my 2019 SE.

After installation, I have the same results as you:
(1) the steering controls work;
(2) the radio works; and
(3) Bluetooth works.

However, the date and time are unavailable to set, and the backup camera does not activate. In addition to the issues you've identified, the new HU does not recognize my USB stick (a problem that extends to Apple CarPlay I imagine), and I get a "Battery Discharge Warning" even though the car is fully powered on.

(I also am not sure what adapters I need to get an XM antenna hooked in, but that's a problem I'd love to get to eventually.)

I suspect I'll need to move some wires around in Connectors A and/or B. Thanks lavr for sharing those diagrams you have. I'll do some more digging and let everyone here know if I find something helpful.
 

Attachments

·
Registered
Joined
·
35 Posts
In addition to the issues you've identified, the new HU does not recognize my USB stick (a problem that extends to Apple CarPlay I imagine), and I get a "Battery Discharge Warning" even though the car is fully powered on.
When I installing 7" HU, I changed USB and AUX box and used USB cable p/n: 96595-A2000 (from KIA Ceed), because in 5" HU for USB four wires, like the same another's wires.
And I had a "Battary Discharge Warning" when engine is working.
When you find wire for rear camera activate, this warning will not be appiar when engine will work.
And I tried to connect GPS antenna in HU, it doesn't help me, clock's still not active.
 

·
Registered
Joined
·
123 Posts
Discussion Starter #16 (Edited)
tc0566, thanks for starting this thread. I purchased a 2019 VE 7" OEM radio to replace the 5" OEM radio in my 2019 SE.

After installation, I have the same results as you:
(1) the steering controls work;
(2) the radio works; and
(3) Bluetooth works.

However, the date and time are unavailable to set, and the backup camera does not activate. In addition to the issues you've identified, the new HU does not recognize my USB stick (a problem that extends to Apple CarPlay I imagine), and I get a "Battery Discharge Warning" even though the car is fully powered on.

(I also am not sure what adapters I need to get an XM antenna hooked in, but that's a problem I'd love to get to eventually.)

I suspect I'll need to move some wires around in Connectors A and/or B. Thanks lavr for sharing those diagrams you have. I'll do some more digging and let everyone here know if I find something helpful.
For your android auto or car play there is a separate 4 pin plug at the back of the radio this can be got on ebay but still it won't work til we can make know the car is running and in park to even set it up.

https://www.ebay.com/itm/Car-Media-Central-Unit-USB-Cable-Interface-Adapter-For-KIA-Hyundai-Tucson/283116435567?ssPageName=STRK:MEBIDX:IT&_trksid=p2060353.m1438.l2649
 
1 - 20 of 37 Posts
Top