Hyundai Forums banner

1 - 20 of 22 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
I kept receiving an error message in my brand new 2021 Elantra Hybrid LTD: Forward Safety system disabled. Radar blocked
The setting for the Warning: Driver Assistance was highlighted for Active Assist, which would avoid having that message appear.
I contacted the dealership several times with no response, and finally this morning I did some research and found that that detection camera is located behind the front license plate. I took off the license plate and the message disappeared. Is anybody else having this issue. Where I live we need a front license plate. Obviously it's not an issue in your state if you only need a rear license plate.
 

·
Registered
Joined
·
2,680 Posts
we have a limited hybrid, with the front plate on. i just went out and looked, the plate is mounted right below the first row of grilles. i think the sensor is up in the mirror mount behind the windshield. we have never had a warning like that. i cannot see any sensors in the grille. and i know what they look like, our sonata has a camera and 2 sensors in the grille. i have spent quite a while polishing both grilles. can you post a pic of the sensor?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
we have a limited hybrid, with the front plate on. i just went out and looked, the plate is mounted right below the first row of grilles. i think the sensor is up in the mirror mount behind the windshield. we have never had a warning like that. i cannot see any sensors in the grille. and i know what they look like, our sonata has a camera and 2 sensors in the grille. i have spent quite a while polishing both grilles. can you post a pic of the sensor?

There are two spots where the sensor is located. One on the windshield and one behind the license plate which I took off. I'm attaching a picture of the exposed sensor after I took off the plate and a picture from the manual showing placement of the sensors.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
Also do you have the driver assistance set to Active Assist in the vehicle settings? IMG_6613.jpg
 

·
Registered
Joined
·
2,680 Posts
yes, active assist is on. we also have it on the sonata, and at least twice, some jerk cut in front, and the system activated, and braked, alarm screaming almost as loud as me. on the elantra, it is not near as good
can you post a pic further out? i took 3 pics. one with license plate off, one with it on, and one with a pic of the front sensor on the sonata(there are 2)
i believe you are referring to the rectangular space right below the plate. also, the manual does say "if so equipped", and i dont think one is there.
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I'm attaching three photos. One with the license plate in tact, one with it removed and the third with the black plate behind the license plate removed. If you can see, the one without both plates there is a sensor above the middle screw hole that is being covered up by both plates (license and black protector plate) Do you have 2021 hybrid LTD also? IMG_6618.jpg IMG_6619.jpg IMG_6620.jpg
IMG_6618.jpg
IMG_6619.jpg
IMG_6620.jpg
IMG_6618.jpg
IMG_6619.jpg
IMG_6620.jpg
IMG_6618.jpg
IMG_6619.jpg
IMG_6620.jpg
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #7 ·
I actually think I see the issue. There is a black styrofoam block that is behind the sensors which I can't seem to get at. I put my hand in the grill and see and feel a black block. It probably needs to be removed because as I now see, there are three sensors: one behind the license plate and two on the left and right. Will bring the car in tomorrow and have them remove that black styrofoam block. Stay tuned
 

·
Registered
Joined
·
2,680 Posts
hybrid limited. and on our car, that hole you are referring to is where the center screw for our plate mount goes in to. notice that our plate is higher than yours. looking at our plate, it is designed to fit exactly just one row down. yours is 2 rows down. the upper outer edges on yours are smooth, on ours it is kinda grooved so that it sits exactly centered. it is really difficult to get behind that lower rectangular part of the grille, that looks like just a smooth, blank space. but i can see an electrical connector behind it. i think if you remount the plate bracket one row higher, the problem will go away. also, if you look at the 3rd row down, where you say the sensor is, that is actually an indentation for the plate mount screws. and it seems like you can mount the plate off to the side, and one row higher. maybe use zip ties to temporarily mount the license, and see if the fault activates. i think it will be ok higher or off to the side. if not, i will cover up the lower part on our car(i gotta get my wife's permission first) and see if that throws the fault
 

·
Registered
Joined
·
2,680 Posts
I actually think I see the issue. There is a black styrofoam block that is behind the sensors which I can't seem to get at. I put my hand in the grill and see and feel a black block. It probably needs to be removed because as I now see, there are three sensors: one behind the license plate and two on the left and right. Will bring the car in tomorrow and have them remove that black styrofoam block. Stay tuned
i see that foam block, ours has it too. it is loosely in there, perhaps some sort of packing protection for the bumper cover. but i dont think it is the cause. i think mounting the license plate higher or off to the side will take car of it. however, if the dealer does remove that foam, let me know.
 

·
Registered
Joined
·
2,680 Posts
btw, if you do take the plate off, check and see if there is a large foam block behind the grill where the license plate goes. it is possible it is a packing piece, and needs to be removed
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #16 ·
Well the verdict is in. The dealership drilled the holes for the black license plate mount in the wrong spot, causing the sensor to be blocked by the license plate. They re-drilled the three holes for the mount and screwed in the license plate and the issue has been resolved.
 

·
Registered
Joined
·
2,680 Posts
Well the verdict is in. The dealership drilled the holes for the black license plate mount in the wrong spot, causing the sensor to be blocked by the license plate. They re-drilled the three holes for the mount and screwed in the license plate and the issue has been resolved.
excellent. can you check your ventilated seats? our driver side seems to be near non existent. the passenger seat on low puts out way more than the driver side on high
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #18 ·
I actually tried the ventilated seats and it works perfectly! One thing I don't have to deal with.
 

·
Registered
Joined
·
2 Posts
Front licence plates are mandatory in Australia, but we have a slim-line plate compared to the OP's Texas plate. The plate is mounted so as to totally clear the flat black rectangle where the radar is located, leaving two slots of open grilles above the plate - see screenshot below from the Hyundai Australia web page. (The MY21 Elantra is badged as an i30 Sedan in Australia.)

You'd need to mount bigger plates higher up to totally clear the radar - but you'd need to check that you're not obstructing cooling ventilation to the radiator. Local Hyundai dealers should know the appropriate location and mounting details.

458592
 

·
Registered
Joined
·
2,680 Posts
Front licence plates are mandatory in Australia, but we have a slim-line plate compared to the OP's Texas plate. The plate is mounted so as to totally clear the flat black rectangle where the radar is located, leaving two slots of open grilles above the plate - see screenshot below from the Hyundai Australia web page. (The MY21 Elantra is badged as an i30 Sedan in Australia.)

You'd need to mount bigger plates higher up to totally clear the radar - but you'd need to check that you're not obstructing cooling ventilation to the radiator. Local Hyundai dealers should know the appropriate location and mounting details.

View attachment 458592
yah, well, if you look at my pics, the plate DOES sit higher
 
1 - 20 of 22 Posts
Top