Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Good evening “newbie” room...!!..
Ok so I’m the new guy here...I do have a question and wanted to post it in the correct forum, but this one says for new members.
I have a 2017 Tucson 1.6 Sport and it seems to always lose power when accelerating. If I put it in the “sport” mode, it really picks up and you, at least I can, def feel the power/horsepower pickup and the car doesn’t lose power when accelerating. Only in the “reg”mode. Anyone else experiencing this...??...My wife was driving it a few days ago and she said she stopped to make a left turn, waited for oncoming traffic to pass, and then when she stepped on the gas, the car slowed dramatically then picked up again. She said thank god no car was going faster or was closer on the oncoming traffic side as “something” terrible could have happened. It’s really starting to piss me off....any other Tucson drivers experiencing this, PLEASE reply back so maybe we can band together and possibly, do something about this before someone gets seriously injured in a car accident due to the vehicle losing power just when you need it the MOST...!!....Thanks....!!
 

·
Registered
Joined
·
480 Posts
It's a fairly common issue with the dual clutch transmission (DCT).
Google "Tucson DCT problems" or look at carcomplaints.com and you'll see you're not alone.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #5
Ok def will do...but is there any “fix” for it, OTHER then get a diff car...lol...??....thanks for the reply bud...
 

·
Registered
Joined
·
5,241 Posts
That's what I meant about 'get used to it'.......that's the way they work.
 
1 - 6 of 6 Posts
Top