Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
2017 SFS 2.0 T Ultimate
Joined
·
765 Posts
Discussion Starter #1
I'm not sure if this is something new, but I normally park in a parking garage, and have the car parked inside my own garage most of the time.

However, due to "telecommuting" I've had twice where the vehicle has been in a non- covered parking lot (really hot 90 F days) for many hours. When I go to start the vehicle it "turns over" for quite a long time, (IMO). I'd say one day was at least 4-5 seconds (normally it's like 1-2, maybe).

Any ideas?
I did have new spark plugs put in about 3 months ago, although hit a deer shortly afterwards, and they had to replace the radiator and fan (the rest was cosmetic stuff), AFAIK. So not sure if that's it either.

Engine temp is fine, AFAIK (according to the dashboard).
 

·
Registered
Joined
·
6 Posts
i think you and me have the same issue, sometimes for seemingly no reason mine cranks for a few extra seconds before starting, never had a stall or experienced any sort of hiccup while driving, just sometimes a longer start, a member suggested a failing pick-up pump in the tank, i am inclined to believe he is correct, now im just trying to figure out how long i have to replace it as im sure parts plus labor will easily top a couple grand...
 

·
Registered
2017 SFS 2.0 T Ultimate
Joined
·
765 Posts
Discussion Starter #3
Thanks for the info. Ironically it only did it like 3 times. Hasn't done it since, even on the days we had like 93 for the high
 
1 - 3 of 3 Posts
Top