Hyundai Forums banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I have a 2017 Elantra. About a month ago when I was in stop and go traffic I lightly tapped the gas to move forward and the engine began to shake like it was going to stall. I gave it a bit more gas & it smoothed out. A couple days later it repeated in the parkade at my work. Same situation with stop & go. The CEL never came on.

I took it to the dealership where the scanned it and didn’t find any codes. they told me that the issue was low oil pressure due to a ‘non-Hyundai’ filter being used. They did an oil change and told me if the problem came back it is likely the oil pump needing replacement.

It has now been 3 weeks and it did it again today. Also in stop & go traffic. Once I give it a bit more gas it smooths out. I don’t believe it’s the oil pressure. The oil light has never come on & I have never seen any signs of an oil leak under my car. Every time it has happened the car has been warm. It has never done it at idle. Only when the gas is pressed lightly. The CEL has never come on.

I am hesitant to go back to the dealership b/c they will insist it is the oil pump. Does anyone have any thoughts?
 

·
Registered
Joined
·
1,449 Posts
There is a recall on the ignition coils. When they fail it can be intermittent. The Yura OEM plugs can have issues fouling or misfire. I replaced plugs early and coils with OEM updated shaft design coils to prevent issues down the road. Regarding the oil pressure claim I have heard Hyundai claiming only their filter will work. I have used Fram Ultra without issues. If there is another dealership available I would get a second diagnosis/opinion.
 

·
Registered
2017 Elantra 2.0 SE non turbo
Joined
·
12 Posts
Yes have your dealership replace all 4 coils with new design. Take a video every time this happens and keep a history to show the dealership. They did not want to replace mine because cel was not staying on so I emailed the service manager every time until they fixed. Also for some strange reason my 17 Elantra 2.0 non turbo runs way better on 5w30 instead of 5w20 go figure
 
1 - 4 of 4 Posts
Top