Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Question..I have a 2015 Sonata Hybrid Limited with the 2.4, and when the engine is fully warmed, it will start jerking when slight throttle is applied. It happens mostly around town, between 35-45 mph. It feels rythmic, and only does it when NOT in EV mode with accelerator pressed. When I go to manual shift mode, it goes away.
It never happens when in EV mode, or when I have the cruise on..also occurs when blue drive is on or off... does anyone know what it could be? I scanned for codes, there are none. No other error messages on the dash. Thanks in advance!
 

·
Registered
Joined
·
362 Posts
I doubt they will change the oil and test the car. They don't think like that.
I suggested it as a predealer activity.
 

·
Registered
Joined
·
2 Posts
Question..I have a 2015 Sonata Hybrid Limited with the 2.4, and when the engine is fully warmed, it will start jerking when slight throttle is applied. It happens mostly around town, between 35-45 mph. It feels rythmic, and only does it when NOT in EV mode with accelerator pressed. When I go to manual shift mode, it goes away.
It never happens when in EV mode, or when I have the cruise on..also occurs when blue drive is on or off... does anyone know what it could be? I scanned for codes, there are none. No other error messages on the dash. Thanks in advance!
I have the same car. Mine was doing this for a while. Yesterday, it did it again as I was exiting the highway and reapplying the throttle after coming to a complete stop and the car died shortly afterwards. "Check hybrid system", "please stop the car" messages started popping up. Car would not restart, had to get it towed to my house, and with social distancing rules, I could not ride with the tow truck driver. So took the bus home, logged my obd2 scanner and am getting code p1b77. After doing a little research on youtube, i found this video:


So I went ahead and ordered the parts and hopefully after I install everything the car will start working again. According to the video the problem is with the power relay assembly and the safety plug, both need replacing.

I am hoping that this is not your problem, but again my car was doing the same thing as you described for a while and I have gotten the check hybrid system message a couple times before, but on prior occasions it went away after stopping the car and restarting it. But this time, it looked like it was a terminal problem. Hopefully OP does not run into my situation. The dealer will charge an arm and a leg for this job and my car was out of warranty. So if you can DIY you are good.
 
1 - 6 of 6 Posts
Top