Hyundai Forums banner
1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
In my quest to figure out why I have no GPS signal in my car, I came upon this thread.

I cannot post links yet, but if you search for:
"Telematics System Error - GPS Disabled" on this forum, you'll find the post I was reading.


I know how to get to my engineering menu, however, where did this screen come from? Does anyone know how to get to it. This is the same car with the same radio as mine.





I know my bluelink has stopped working and I pick up NO sattelites at all. I wanted to run the same test as what he ran in the above post, but cannot figure out how to get to that menu.

Any help would be greatly appreciated.


Thanks in advance.
Pat
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #2 · (Edited)
So I have been doing a ton of research lately on this problem, and I have yet to come up with anything close to fixing the problem. As of now there are two of us on this forum with the exact same problem. So I'm sure there has to be other cases out there.

Here is the issue: There is NO gps signal. No sattelites being picked up at all. I have learned how to access Engineering mode, Dev mode, and the telamatics diagnostics menu. In the attached photos, you will see the GPS information showing NO sattelites, and the telematics diagnostic screen showing the failures.

So far, between myself and the other user on this forum with the same problem, the radio has been replaced, roof antenna, MTS module. And neither of the three have fixed the issue.


I have some general ideas how to troubleshoot the canbus system, but I honestly don't know which direction to go with this problem. Has anyone else seen this problem? And what was the solution?
 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
Been digging around with the wiring for the nav unit, etc... now I have other problems that popped up. IE. Door pushbutton to unlock the doors on drivers side no longer works. Clock on the radio doesn't stay set... ETC. So I'm sure that it's a canbus problem. However I cannot find any full fledged schematics on this car. I'm an electrician by trade, and spend alot of time looking at prints and troubleshooting.

If anyone knows where I can find electrical schematics that shows the canbus routes and all the wiring, it would be greatly appreciated.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #4 ·
So... I took my car to the dealership to have numerous recalls fixed. At the same time they checked out my nav system to see if they could pinpoint the problem. They tested the roof antenna to the radio and it came out ok. And after several other tests they told me that they were sure (99 percent) that it was the radio. So my thinking was.... Well they should know what they're talking about. So I got a good deal on a manufacture refurbished radio still wrapped in plastic and the foam/boxed up. Got that, tried it out and I get the same problem. Replaced the telematics module and still have the same thing.

Now.. There are two of us on this forum that I know of that are having this problem. I can't believe we are the only two out there. Whatever the case is... Here is my question.

What other systems tie into the navigation radio that would prevent the GPS signal to getting to the radio???

I'm completely lost. I just can't believe no one else has this issue.
 
1 - 5 of 5 Posts
Top