Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Intermittent starting problems.
Today, car started perfectly. I went to lunch (approx one hour), and car started perfectly again. I then drove to a store and came out after 10 mins, car wouldn't start. After 5-6 attempts, it started. Drove 15 mins to the house & it started fine in the driveway. It might work fine for the 2-3 days and it'll do it again.
It's got a new battery, new key FOB battery and cranks fine. Sounds like a fuel and/or ignition problem.

Anyone experience this same issue?
 

·
Registered
2013 Hyundai Santa Fe Sport
Joined
·
2,278 Posts
Another member had this same issue. Turned out to be the in tank fuel pump failing.

Get a scan tool hooked up and check fuel pressures (there is no physical port on the fuel rail). Forget what the required holding pressure is but thinking yours is losing fuel pressure while sitting. Then the pump has to get the system repressurized but engine will fail to start until this occurs.

Sent from my SM-G965U1 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
That definitely sounds plausible. Sounds like I difficult issue to diagnose unless I get lucky & it happens while connected.

Thanks
 

·
Registered
Joined
·
1,548 Posts
failing crank sensors can behave like this also. If the tacho is dead whilst cranking that can be a clue
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Hmmm, haven't paid attention to the tach. That part is less than $70 and not that difficult to change so probably a good starting point. I'll let you know, thx.
 
1 - 5 of 5 Posts
Top