Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter #1
Been awhile since I had to post, the SF has been running pretty good. Just wanted to give an update to 2 issues I had during my 30K mile service in the case anyone else out there experiences some issues.

1st - The stalling problem happened to me unfortunately or lucky before my service. I rolled up to a stop sign, and my car completely shut off. No power no nothing. I could also not restart the car until I took the key out, and put the car into park & put the key back in.
I took the car in, and they replaced a recalled Throttle Body. Apparently my 2012 had a model that was defective. Problem has not reoccurred and my low idle issues in the past are nowhere to be found. Yea!

2nd - right after my service, I noticed an incredibly loud whine as the car gathered speed and shifted gears. The noise was NOT there ever before. I though maybe since I had my service it had something to do with lubricants or other. But the whine did not go away and happens 100% of the time.

I took it in yesterday and they immediately diagnosed the problem as Defective Idler Pulley They replaced the pulley free of charge, and sure enough the whine is gone. Runs better too. (at least it feels that way)

So if you experienced these 2 issues have your dealer check em out.

While I love my Hyundai SF, I have to say having 2 parts so far fail or diagnosed as bad concerns me. I just hope this is the last of failed or bad parts.
 

·
Registered
Joined
·
50 Posts
I always found it funny how things seemed to go wrong right after you brought a car in for warranty service....I'm just saying.
 
1 - 2 of 2 Posts
Top