Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I just bought a used Tucson Limited, 2011, with 30,000 milles. The Hyundai dealer went out of business the day after my purchase. The car works fine, except when I am on the expressway, going 70 miles per hour or higher, the sun roof has a loud humming sound. Any suggestions on how to fix this? Is it a common problem with this model? Should I buy a wind protector shield? Should I call another dealer for advice?
 

·
Premium Member
Joined
·
2,744 Posts
Welcome to the forum
Moved your post to "LM" 2010-up forum for better response.

By the way, your warranty should still valid, go to any other Hyundai dealership for the warranty repair.
My sun-roof has no problem, though I seldon open it. Just test it once a month to make sure the motor & mechanism runs .
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I have an appointment with a Hyundai dealer in another city tomorrow morning. It is nice to know about your sun-roof and to ask about the warranty for my car. Thanks very much. I'll let you know how everything works out.
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #4 ·
Update -- I went to another dealership an hour away. They fixed the problem, at no charge. Seems that someone had adjusted the front of the sun roof to a higher position. The tech readjusted it back to the original position, flush with the body of the car when closed. It is working fine now.
 
1 - 4 of 4 Posts
Top