Hyundai Forums banner

1 - 11 of 11 Posts

·
Registered
Joined
·
475 Posts
Discussion Starter #1
My car has 103,xxx miles. And just recently I have noticed that dash lights in the center counsel, steering wheel and indicator lights (headlights and fog lights) flash on and off when I either 1. use the turn signal switch to indicate a lane change or 2. on there own when driving at night. What can cause this? Do I need a new turn signal switch? Prior to taking video, I was driving at night and my headlights went out, along with dash center counsel lights. They came back on and had no issues. I parked at a restaurant and recorded a small video but it is not letting me upload because mp4 format is not allowed.

Any thoughts ? **I do have aftermarket headlights and rear taillights but I have had them for over a year now with no issues, this cannot be the cause**
Thanks
Edgar
 

·
Registered
Joined
·
1,093 Posts
Ground issue or signal stalk issue. With the lights on try rotating the switch up past the Auto position, and they may all turn off. Could just be buildup and not good contact so cleaning could be done. Otherwise full replacement.
 

·
Banned
Joined
·
7,039 Posts
My car has 103,xxx miles. And just recently I have noticed that dash lights in the center counsel, steering wheel and indicator lights (headlights and fog lights) flash on and off when I either 1. use the turn signal switch to indicate a lane change or 2. on there own when driving at night. What can cause this? Do I need a new turn signal switch? Prior to taking video, I was driving at night and my headlights went out, along with dash center counsel lights. They came back on and had no issues. I parked at a restaurant and recorded a small video but it is not letting me upload because mp4 format is not allowed.

Any thoughts ? **I do have aftermarket headlights and rear taillights but I have had them for over a year now with no issues, this cannot be the cause**
Thanks
Edgar
Could be a ground but I'm thinking the multiswitch is not connected well or has internal problem. Wiggle it and see if you can make it fail/work. If so check it's connection. If that's not a problem the switch(s) may be the problem.
 

·
Registered
Joined
·
2,455 Posts
grc, if someone gives a good response (forgeinaz) there really isn't any point in saying almost the same thing! No offense, just my take! :wink2:
 
  • Like
Reactions: forgeinaz

·
Registered
Joined
·
475 Posts
Discussion Starter #6
Read here many times from the guys that usually it’s a ground problem.
The ground wire from the connector of the turn signal switch assembly? I do have the trim removed from around the steering wheel assembly and exposing the switch connector..
 

·
Registered
Joined
·
475 Posts
Discussion Starter #7
Ground issue or signal stalk issue. With the lights on try rotating the switch up past the Auto position, and they may all turn off. Could just be buildup and not good contact so cleaning could be done. Otherwise full replacement.
I have done this where I wiggle the switch assembly and the lights (exterior and dash counsel, steering wheel controls) will turn off and back on or if I push the switch inwards and does the same thing
 

·
Registered
Joined
·
4,088 Posts

The ground wire from the connector of the turn signal switch assembly? I do have the trim removed from around the steering wheel assembly and exposing the switch connector..
I was thinking more of the negative cable from battery that connects to the chassis itself. But maybe it’s the actual stalk itself!
 

·
Registered
Joined
·
475 Posts
Discussion Starter #9
I was thinking more of the negative cable from battery that connects to the chassis itself. But maybe it’s the actual stalk itself!
if that were the case, it would have effected more than just what I mentioned. Need to see where that ground wire from the switch connector leads to under the dash.
Thanks
 

·
Banned
Joined
·
7,039 Posts
if that were the case, it would have effected more than just what I mentioned. Need to see where that ground wire from the switch connector leads to under the dash.
Thanks
I think you can try contact cleaner on the connector for the multiswitch and see if that corrects it.
 

·
Registered
Joined
·
1,093 Posts
I have done this where I wiggle the switch assembly and the lights (exterior and dash counsel, steering wheel controls) will turn off and back on or if I push the switch inwards and does the same thing
You can try contact cleaner like GRC said or replace the stalk. It is somewhat common thing.
 
1 - 11 of 11 Posts
Top