Hyundai Forums banner

1 - 17 of 17 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hey guys, new to cars, I was wondering if anyone can give me insight into my experience with my new genesis. I bought it about 3 weeks ago with 145k. About a week ago I topped up the tank with sunoco regular. Suddenly, after about 3 minutes of driving it the engine light went on and suddenly went into limp mode. I pulled over, restarted it, and it drove like normal, albeit with the light still on. I scanned it and got P0638, P1295, P2106. I figured since it was functioning normally I'd reset the codes and see what happens. By next morning before I did anything the light turned off by itself. Now a week or so later, I filled up a full tank at a different sunoco. A few minutes later, on the highway the same thing happened, it started limping, I pulled over restarted the engine and it's back to normal.
Can anyone please give me insight into what it might be, and why it happens after I fill it up? Please explain in layman terms. Thanks!!
 

·
Premium Member
Joined
·
2,745 Posts
Welcome to the forum
Please fill in your profile, location, model, year, trim etc
Private sale or thru a dealership??
You can post on the Geneis forum for better response.
 

·
Registered
Joined
·
17,552 Posts
Hey guys, new to cars, I was wondering if anyone can give me insight into my experience with my new genesis. I bought it about 3 weeks ago with 145k. About a week ago I topped up the tank with sunoco regular. Suddenly, after about 3 minutes of driving it the engine light went on and suddenly went into limp mode. I pulled over, restarted it, and it drove like normal, albeit with the light still on. I scanned it and got P0638, P1295, P2106. I figured since it was functioning normally I'd reset the codes and see what happens. By next morning before I did anything the light turned off by itself. Now a week or so later, I filled up a full tank at a different sunoco. A few minutes later, on the highway the same thing happened, it started limping, I pulled over restarted the engine and it's back to normal.
Can anyone please give me insight into what it might be, and why it happens after I fill it up? Please explain in layman terms. Thanks!!

Complete your profile so we can help you based on which market you in, and which engine...

Mark613
Junior Member
Location --> ____________

Drives 2011 BH Genesis 3.8 or 4.6

Join Date: Mar 2018
Posts: 1
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Mark613 is an unknown quantity at this point
(Thread Starter)


Depending on engine, there is TSB for that (3) code set (USA),,, and an update to be installed also

Currently dont have enough info to proper explanation,, help us help you..
 

·
Registered
Joined
·
12 Posts
Discussion Starter #4
Hey, I'm so sorry for not responding. I don't have much experience using forums; I assumed I will get an email or something if someone responds. Just a brief update, I took it to a shop, and it turned out that it was happening due to me leaving the engine running while refueling. I stopped doing this, and the problem was eliminated until recently. But lately it started happening again with increasing frequency which is a total safety hazard...

To answer your questions, it's the v6 3.8 engine with tech package, and I'm in New York State. It was purchased from a private company, formerly used as an uber black.

Thanks so much, and it would be great if I can get a solution before the shop puts in a new throttle body...
 

·
Registered
Joined
·
17,552 Posts
Hey, I'm so sorry for not responding. I don't have much experience using forums; I assumed I will get an email or something if someone responds. Just a brief update, I took it to a shop, and it turned out that it was happening due to me leaving the engine running while refueling. I stopped doing this, and the problem was eliminated until recently. But lately it started happening again with increasing frequency which is a total safety hazard...

To answer your questions, it's the v6 3.8 engine with tech package, and I'm in New York State. It was purchased from a private company, formerly used as an uber black.

Thanks so much, and it would be great if I can get a solution before the shop puts in a new throttle body...

EDIT --- WRONG INFO GIVEN,, TSB for TPS replace only to 2010 BH Genesis
 

·
Registered
Joined
·
17,552 Posts
And how much labor are we talking?
Note change in previous post,,, TPS and PCM Update only 2009 to 2010 with BH Genesis...

You will end up with Throttle Body replacement
 

·
Registered
Joined
·
12 Posts
Discussion Starter #9
Does that mean I should cancel the order on tps and instead order a throttle body assembly?
 

·
Registered
Joined
·
17,552 Posts
Does that mean I should cancel the order on tps and instead order a throttle body assembly?

I would say yes to cancel TPS,, I seemed to recall a production change somewhere around that time frame to where that TPS was replaced with self contained unit on throttle body
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
I was on the Hyundai part store, and they were selling the same throttle body for 2009, 2010 and 2011 models. Correct me if I'm wrong, but wouldn't this be sufficient evidence that my 11 has the same tb system as the 09 and 10, and therefore I can replace the tps as a separate unit, as per the tsb?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #14
Hey, I'm so sorry for not responding. I don't have much experience using forums; I assumed I will get an email or something if someone responds. Just a brief update, I took it to a shop, and it turned out that it was happening due to me leaving the engine running while refueling. I stopped doing this, and the problem was eliminated until recently. But lately it started happening again with increasing frequency which is a total safety hazard...

To answer your questions, it's the v6 3.8 engine with tech package, and I'm in New York State. It was purchased from a private company, formerly used as an uber black.

Thanks so much, and it would be great if I can get a solution before the shop puts in a new throttle body...

EDIT --- WRONG INFO GIVEN,, TSB for TPS replace only to 2010 BH Genesis
Ended up going with your original solution, $25 TPS on Amazon, and 10 minutes labor. Thanks a ton!
 

·
Registered
Joined
·
17,552 Posts
Ended up going with your original solution, $25 TPS on Amazon, and 10 minutes labor. Thanks a ton!
Pics of throttle body,, not sure why TSB stopped at 2010... If you was able to replace, that good,, might have dealer verify engine program latest version
 

·
Registered
Joined
·
12 Posts
Discussion Starter #16
Ended up going with your original solution, $25 TPS on Amazon, and 10 minutes labor. Thanks a ton!
Pics of throttle body,, not sure why TSB stopped at 2010... If you was able to replace, that good,, might have dealer verify engine program latest version

Pics of tb? I don't understand... Anyway it gets complicated... Cel and limp mode came on after a while. Took it to dealer, Ecu was up to date... Was told to come back after Thanksgiving to further diagnose... At least I got away without changing tb. Tsb was put out in 2010 so obviously wouldn't include 2011 model...
 

·
Registered
Joined
·
12 Posts
Discussion Starter #17
Update: ended up replacing entire throttle body as per dealers recommendation, and problem is fixed.
 
1 - 17 of 17 Posts
Top