Hyundai Forums banner

1 - 9 of 9 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all, I'm new to the forum. I've used the search feature and thumbed threw a few hundred topics and couldn't find the issue I'm having. My car being a 2011 the daytime running lights come on as standard when the ignition is on except when I turn the headlights on. Just recently I noticed that they don't turn on anymore, along with the function of my high beams. I'm positive they both stopped working on the same day. I know there's no set fuse for the headlights, and I've replaced the turn signal/headlight switch on the steering column to no resolve. Has this happened to anyone, or does anyone have an idea of whats going on? I appreciate any input. Thanks
 

·
Registered
Joined
·
1,340 Posts
Have you replaced the bulbs? If so, make sure there is power going to the sockets.
 

·
Registered
Joined
·
17,552 Posts
You going to need DVOM and wire diagram,, but based on your text, and roughing it at Hyundai site (ETM).. I suspect you have fault with Smart Junction Box (I/P module - instrument panel fuse block) .. I just replace 1 here last week, part was around $430 I think it was..

 

Attachments

·
Registered
Joined
·
4 Posts
Discussion Starter #4
Thanks for the quick responses. I haven't looked at the bulbs or sockets quite yet, but I plan on doing so tomorrow. I'm hoping its not the I/P module just for the cost, haha. But I'll definitely look into the bulbs and make sure the sockets haven't burned or anything, then I'll move toward the fuse block later. I appreciate your input. If anything changes I'll post again.
 

·
SENIOR MODERATOR
Joined
·
9,284 Posts
The high beam/DRL bulb is an H1 and they tend to get very fragile as they age. One good shock may have been more than both of them could take.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Update. I have replaced the turn signal selector/highbeam switch and the smart junction box and still no daytime running lights or high beams. I'm still searching for the problem. Can't seem to figure this car out.
 

·
SENIOR MODERATOR
Joined
·
9,284 Posts
Have you replaced the bulbs? The daytime running light is just the H1 high beam bulb being run at reduced power.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Have you replaced the bulbs? The daytime running light is just the H1 high beam bulb being run at reduced power.
I thought I checked the bulbs thoroughly enough, but apparently I didn't. Every time I have pulled the bulbs the filament looked fine, but when I changed them earlier the filaments had jarred loose and dangling in the bulb. I didn't realize the drl was also the hi-beam, which is what confused me (even tho you stated that in December I believe I misread it. But they work now and I'm very happy. Thanks so much lovemysantafe and everyone else who gave advice . Definately happy with the input from this forum.
 

·
SENIOR MODERATOR
Joined
·
9,284 Posts
I thought I checked the bulbs thoroughly enough, but apparently I didn't. Every time I have pulled the bulbs the filament looked fine, but when I changed them earlier the filaments had jarred loose and dangling in the bulb. I didn't realize the drl was also the hi-beam, which is what confused me (even tho you stated that in December I believe I misread it. But they work now and I'm very happy. Thanks so much lovemysantafe and everyone else who gave advice . Definately happy with the input from this forum.
Glad we were able to help.
 
1 - 9 of 9 Posts
Top