Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My 2010 Santa Fe Limited AWD V6 Auto has a factory remote start that used to work well. It stopped working sometime last year for one of my FOBs (door lock function still works fine). It would flash the park lights once to acknowledge as it always did, but then flash 3 more times as what I believe is an error code. Out of laziness I switched to using my 2nd FOB since it still worked, but now it has stopped too. It gives a 2-flash error code after the acknowledgement flash. I can't seem to find what these flash codes relate to, but I'm hoping this is a simple reset/pair procedure I can do myself. Maybe something was accidently disconnected or lost pairing during a garage service.

Can anyone tell me what these codes mean and if/how I can fix it myself?

Thanks.
 

·
Registered
Joined
·
36 Posts
on my 09 the remote unit product number is HY-1774 and I used this Autostart manual to troubleshoot my unit https://lockdownsecurity.app.box.com/s/xao468w8i0h8wb8xulfr
is the blue light on antenna in the car on? if yes, you have it valet mode and your car wont start.
Also some keys on key fob stopped working properly so I replaced it, recoding wouldnt help. Seems like the fobs can get bad
 

·
Registered
Joined
·
2 Posts
Discussion Starter #4
on my 09 the remote unit product number is HY-1774 and I used this Autostart manual to troubleshoot my unit https://lockdownsecurity.app.box.com/s/xao468w8i0h8wb8xulfr
is the blue light on antenna in the car on? if yes, you have it valet mode and your car wont start.
Also some keys on key fob stopped working properly so I replaced it, recoding wouldnt help. Seems like the fobs can get bad
Thanks, Pete! That was exactly the information I needed. It turns out it was stuck in valet mode, but it wouldn't deactivate with the remote for some reason. I had to use the key and do the 5 times on/off to release it. The mechanic who serviced it last may have put it in that mode as a precaution.
As for the 1st key fob, I was mistaken - it gave 2 flashes as well, not 3.
 
1 - 4 of 4 Posts
Top