Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Recently my 2010 Santa Fe's remote start key fob is not acknowledging a response for any function on it and there is no blue light activating behind rear view mirror. I figure it has to be something fairly simple since it worked just fine last week. I have two remotes and when buttons are pushed I'm getting bright blue lights on both key fobs so I doubt if both batteries are bad, the factory key fob for door locks still works fine. I've read other posts and I'm aware that there is not many fans of the remote start feature lol but please help its been -30 here in MB for far too long and I need this feature to work for me. :(
 

·
Registered
Joined
·
241 Posts
Creekside,

I love my remote starter but I don't really have specific suggestions for repair. If you're handy, you can crawl in under the dash and check the connections to ensure nothing has come loose and make sure the wire is attached to the antenna on the windshield. If that doesn't work, for the sake of $10 I'd put new batteries into one of the remotes to see if it makes any difference. If not, back to the dealer you go.

Dealer installed accessories like remote starters have a 3-year warranty, so unless yours is a really late 2010 model, its out of remote start warranty now.

Good luck!
 

·
Registered
Joined
·
1 Posts
Had the same issue, and found that someone in our house accidentally ( a few times a year), set our starter in Valet mode (antenna Blue LED is solid), that happens when someone holds down the lock/unlock buttons at the same time.

To remove from Valet mode, holds down the lock/unlock buttons at the same time until the truck lights flash twice (doesn't always flash), for me 5 sec works, and the antenna LED now flashes quickly (normal), then press the start button and there it remote starts normally.

Might not be the same remote but might work for you as well...
 

Attachments

1 - 3 of 3 Posts
Top