Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Greetings, I am about to leave on a trip to florida.. 12 hour drive... I am wanting to correct an issue where my horn and 12v power quit working at the same time. I checked all the fuses and relays. found nothing wrong there. Thoughts on the best way to correct this? I was hoping to even locate a schematic of how it wired.

HELP?!
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,313 Posts
I assume by 12V power you mean the 12V power outlet? If so, I can't think of anything these two circuits have in common that could explain why they would both fail at the same time.

You say you checked the fuses and relays, did you check to see if the horn relay is clicking when you push the horn switch? The horn relay is out on the engine bay fusebox....see below.

 

Attachments

·
Registered
Joined
·
9 Posts
Discussion Starter #3
i've gone as far as swapping them around to eliminate the relay. same problem. I do have a questions about the battery terminals. on my negative terminal there are some yellow wires running back into the firewall area. what would these be? I would really like a schematic. I thought about even just running new wiring. I want to be able to use my electronics and have the horn for safety.

Thoughts anyone?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,313 Posts
Todd Sadler said:
i've gone as far as swapping them around to eliminate the relay
OK, so we know the relay is good. But does it click when you push the horn switch??

Todd Sadler said:
on my negative terminal there are some yellow wires running back into the firewall area. what would these be?
My guess is it's the wiring for the battery sensor. The sensor is on the negative battery terminal and has a two wire connector attached.

Todd Sadler said:
Thoughts anyone?
I'd suggest you try replacing the two fuses highlighted below.

 

Attachments

·
Registered
Joined
·
1,187 Posts
Here are the schematics for the horn and power socket on the 2012 RB Accent.

The power plug schematic shows a clock and cigarette lighter that aren't present in the North American model. But everything else including the wire colors should be OK.

Check that you have 12V where there is supposed to be 12V and check that the grounds are good.. For instance, measure the continuity from the ground of the power plug socket to a metal part of the chassis....
 

Attachments

1 - 5 of 5 Posts
Top