Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
36 Posts
Discussion Starter · #1 ·
Just installed aftermarket headunit and the harness was matched perfectly to the Sonata. But I don't have radio reception. I didn't attach a white wire but I assume that was the USB/aux armrest wire.

Any idea which wire is the antenna wire? I need help.

I've searched the forums and looked up the diagram on hyundai's website- and its still not clear to me. Looks like the antenna wire is one of the wires on the main harness (the harness with 3 parts) but that harness is fully plugged in the adapter. My new headunit has a wire for the antenna- but I thought this was not used- but now I know it must be. I just need help finding out where to attach it.

Thanks.
 

·
Registered
Joined
·
102 Posts
QUOTE (bksonata911 @ Apr 27 2010, 11:02 PM) index.php?act=findpost&pid=317513
Just installed aftermarket headunit and the harness was matched perfectly to the Sonata. But I don't have radio reception. I didn't attach a white wire but I assume that was the USB/aux armrest wire.

Any idea which wire is the antenna wire? I need help.

I've searched the forums and looked up the diagram on hyundai's website- and its still not clear to me. Looks like the antenna wire is one of the wires on the main harness (the harness with 3 parts) but that harness is fully plugged in the adapter. My new headunit has a wire for the antenna- but I thought this was not used- but now I know it must be. I just need help finding out where to attach it.

Thanks.
There is a power unit for the glass antenna on the rear right, behind the front passenger side. Its right next to the glass, you have to take off the rear deck panel then you can take off the side panel. I used a multi meter to find the hot wire that turns on the unit when you turn on the ignition, or ACC mode. On my 06 Nata, the wire was blue, from the power antenna unit. Its a small black box that has 2 wires in front, and the wire connection right off the glass. Hopes this helps. :grin:
 

·
Registered
Joined
·
587 Posts
The issue is that the Sonata has an in-glass antenna which has an amplifier which requires power. All that is needed is to use a wire coming from the new head unit to apply power to the antenna amp. The antenna amp wire is, I believe, green with a silver stripe.

If I recall correctly, when I installed a new head unit in my 06 Sonata I used a wire from the head unit which was intended to supply power to a power antenna to supply power to the antenna amp. Worked perfectly. There is a good writeup on installing a new head unit in the reference materials on this forum home page, stickied at the top.
 

·
Registered
Joined
·
36 Posts
Discussion Starter · #6 ·
QUOTE (rallyman @ Apr 30 2010, 08:33 PM) index.php?act=findpost&pid=318360
The issue is that the Sonata has an in-glass antenna which has an amplifier which requires power. All that is needed is to use a wire coming from the new head unit to apply power to the antenna amp. The antenna amp wire is, I believe, green with a silver stripe.

If I recall correctly, when I installed a new head unit in my 06 Sonata I used a wire from the head unit which was intended to supply power to a power antenna to supply power to the antenna amp. Worked perfectly. There is a good writeup on installing a new head unit in the reference materials on this forum home page, stickied at the top.
Thanks. So my new harness has a blue wire marked "Auto antenna" that leads to the same pin location indicated in an earlier post for the Sonata Antenna.

But the new head unit also has a black "Radio Antenna" cable I think is solely used for reception- whereas the other antenna connection is meant only to supply power.

Can I splice the black wire in with the blue "Auto Antenna" wire to get radio reception? I would like opinions before I rip my dash up again to try.

Thanks.
 
1 - 6 of 6 Posts
Top