Hyundai Forums banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi
When I start my car it works fine, great for city driving but when I go onto motorway and accelerate past 75/80mph the gears drop and rpm will not pass 3000rpm, I lose a lot of power and have to put it into manual and work the gears back up to 5th gear (takes a long time), no engine lights come on at all! When I pull over and restart the engine all works fine again till I reach 75/80mph, iv brought it to Hyundai dealer to diagnose the problem and they've said there's nothing logged that they would have to strip the engine to find the fault! Any ideas?
 

·
Registered
Joined
·
1,280 Posts
Please complete your profile so we know what you drive and where you are.

.
 

·
Registered
Joined
·
4,010 Posts
Any ideas?

Yeah, the Hyundai dealership doesn't know what it is so they BS you
The easiest way to cover their diagnose fee is to charge for something else that cost a lot more.

The fact that when the problem comes up, you pull over and turn it off and restart, it works again
Makes it sound like an electrical/electronics issue.

Good luck
 

·
Registered
Joined
·
1,280 Posts
We don't have the diesels in North America so I'm only guessing, but it sounds like it might be a fuel delivery problem. If the engine runs okay until you start to place some serious demand on it, that (to me) sounds like fuel starvation. If the power drops off and you start to press the accelerator, that would account for the transaxle downshifting. Here are some ideas:

The first thing to check, especially if it's never been looked at, is the fuel filter. Second thing is the possibility of contaminated fuel - someone more knowledgable than I am might know if there is an additive that will kill bacteria and/or clean the system. In fact, you might go that route first, then change the filter after it's caught any gunk. Third thing is a high pressure fuel pump starting to get weak. First and second ideas are less expensive than the third.

If you trace the problem, let us know.

.
 

·
Registered
Joined
·
3,033 Posts
Yeah looking at the owner manual maintenance list might reveal in trouble shooting losing power. Skipping various key services on diesels is not wise and may be a result of no having done something.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
It has full service history, do they change this filter during the service if not is the fuel filter an easy job or would I have to leave it in? I only have the car 3 weeks myself
 

·
Registered
Joined
·
3,033 Posts
That depends, is it in the service records. Service history doesn't mean anything unless there are service details. Otherwise you assume nothing was done other than some oil changes or whatever. Since you just got it you should have ALL filters replaced and any neglected fluids which are important to the diesel.
 

·
Registered
Joined
·
12,659 Posts
FWIW, your issue doesn't sound like a fuel pressure problem to me. Fuel pressure is closely monitored on a CRDi engine and the ECM would almost certainly log a code if the pressure dropped so low that it was causing a driveability issue. You also seem to suggest the problem doesn't go away until you recycle the ignition which doesn't fit with a fuel pressure problem, which would go away as soon as you eased off on the throttle.

My advice is find a diesel specialist in your area and have them check it out. Someone who knows what they're looking for really needs to take the car for a test drive on the motorway with a scan tool to see what parameter is dropping out of spec when you get to 70~80MPH.

It might not even be an engine problem. Since the car has an auto gearbox, maybe it's a transmission fault.
 

·
Registered
Joined
·
1 Posts
Hi
When I start my car it works fine, great for city driving but when I go onto motorway and accelerate past 75/80mph the gears drop and rpm will not pass 3000rpm, I lose a lot of power and have to put it into manual and work the gears back up to 5th gear (takes a long time), no engine lights come on at all! When I pull over and restart the engine all works fine again till I reach 75/80mph, iv brought it to Hyundai dealer to diagnose the problem and they've said there's nothing logged that they would have to strip the engine to find the fault! Any ideas?
Hi I am currently experiencing same problem did you get a solution
 

·
Registered
Joined
·
10 Posts
Hi I have exact same problem. DPF, turbo, mafs sensor, fuel filter, air filter have all been replaced! Any ideas?
 
1 - 12 of 12 Posts
Top