Hyundai Forums banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have an 08 accent GS with 156k on it.
Today after dropping my fiancee at work i got just a few blocks down the road and the car died. I pushed the car over and used my scantool and it pulled up a P0342 Camshaft position sensor code.
When i try to start the car with the key i can hear the starter, but there is no continuous crank. It feels like it wants to crank but then all you can hear is the starter. Even when attempting to pop the clutch the car feels like it wants to start, but immediately just dies.
Thank you in advance, this is our only running vehicle at the moment.
 

·
Registered
Joined
·
2 Posts
I just had the same problem today on my way home from work. I also own a 2008 GS. I have 131000 miles on it. I don't have a scan tool. I've never had my timing belt replace.
 

·
Registered
Joined
·
2 Posts
2008 Hyundai Accent GS died and wont start

I seem to have same issue. My GS died just about a mile from my home. It will continuously crank, but it will not start. I don't have a scantool to see what the code is. I may need to get one and see if my code matches yours. I have 131000 miles on mine, and the timing belt has not been changed on it yet.
 

·
Registered
Joined
·
3,919 Posts
Take oil filler cap off the valve cover
See if you can spot the valves
(may need a flashlight/torch)
Then have someone crank engine
Does the valves move?
If not then engine may have a failed timing belt
(interference engines, the failure of a timing belt usually means damage to engine)

If not then scan ECM/computer and read codes
Proceed from there
 

·
Premium Member
Joined
·
871 Posts
I have an 08 accent GS with 156k on it.
Today after dropping my fiancee at work i got just a few blocks down the road and the car died. I pushed the car over and used my scantool and it pulled up a P0342 Camshaft position sensor code.
When i try to start the car with the key i can hear the starter, but there is no continuous crank. It feels like it wants to crank but then all you can hear is the starter. Even when attempting to pop the clutch the car feels like it wants to start, but immediately just dies.
Thank you in advance, this is our only running vehicle at the moment.
DTC P0342 info.
 

Attachments

·
Registered
Joined
·
3 Posts
I don't know about yours, but my problem is snapped belt.
Checked all the relays and fuses first. Then tried with the sensor, then tested the cabling and finally unscrewed the two top bolts on the timing belt cover and the belt was touching the cover. Merry Christmas to me!
 

·
Registered
Joined
·
7,477 Posts
I don't know about yours, but my problem is snapped belt.
Checked all the relays and fuses first. Then tried with the sensor, then tested the cabling and finally unscrewed the two top bolts on the timing belt cover and the belt was touching the cover. Merry Christmas to me!
Rock Auto .com has rebuilt heads for the 1.6L.
 

·
Registered
Joined
·
3 Posts
Rock Auto .com has rebuilt heads for the 1.6L.
Sorry to hear that. Hopefully there isn't any damage and you get away with just replacing the belt.

Fingers crossed for you.
Rock Auto .com has rebuilt heads for the 1.6L.
Thank you guys. Just got a call from the shop, they said only 1 of the cylinders checked in with good compression. :(

If I get a head from this website, will it work for sure or the pistons have to be inspected too?
 

·
Registered
Joined
·
7,477 Posts
You won't know for sure until you take the head off but that usually just bends the valves and puts a nick on the pistons. Hopefully the valve did not stick in to the piston.


Might want to take the head off first, you will also know all the gaskets you need too then.
 

·
Registered
Joined
·
12,165 Posts
Just got a call from the shop, they said only 1 of the cylinders checked in with good compression.
I assume they replaced the belt and reset the timing before doing the compression test? The results of the test are meaningless if they didn't.
 

·
Registered
Joined
·
3 Posts
Was this issue ever resolved I am having the same problem with my 07 Hyundai Accent, I replaced the Camshaft Position Sensor and the issue and code P0342 is still there.
 
1 - 19 of 19 Posts
Top