Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hi, first of all new to the forum, how is everyone?

I currently drive a 58 plate 7seat CRTD automatic santa fe (registered 2009), whilst out driving today i noticed an issue when pulling into a car park, up until this point the car worked fine.
Upon slowing it would appear that the back brakes (i assumed this) were locking up as i could hear screeching noises on the tarmac, the steering became very heavy and starting vibrating, pulling into the space without the car in motion it was vibrating more than would be expected for a diesel.
On exiting the car i smelled what can only be described as clutch or transmission as the brakes appeared to be fine.

On my return to the car, i reversed out of the space, the vibration immediately returned followed by loud clonking and the transmission becoming jumpy. Driving home, the steering would become distant then very hard, the vibration would become intermittant (appearing only at lower speeds).
No lights have been presented on the dash so i can only assume this is a mechanical issue. After checking engine oil and transmission oil, both appear to be fine.

Has anyone else come across this issue? If so would it still be covered under manufacturers warranty?

I use the car mainly for commuting but regular use it for transporting the kids, i dont feel safe taking them anywhere at the minute.

Regards
Dave
 

·
Registered
Joined
·
843 Posts
Hi Dave,
Because I cannot imagine this to be normal, I suppose your automatic gearbox or it's drive train to the wheels has some serious gear issues.
I do not suppose one of your wheels has become somewhat detached by loss of some attachement bolts.
So I would think a visit to a garage or dealership would be in order.
Good luck,
Paul
 
1 - 2 of 2 Posts
Top