Hyundai Forums banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello. I have a 2007 Hyundai Tucson se. Only one speaker (front passenger side) is working. My husband bought me a new radio and replaced it thinking that just the old head unit was no longer any good. All speakers worked for about a day after installing the new head unit. All.of a sudden only 2 speakers were working. He then rewired all of my speakers and now back to only the front passenger speaker working. If anyone has had these or similar issues Please Help!!!

Before he replaced the head unit we reset the factory radio by pushing a paperclip into the pinhole next to the CD player. This only worked for a little while. Then we tried it again and it wouldn't work anymore. After reading about it we found that a lot of Hyundai's have this issue. The previous owner of the car must've pressed it so many times that the reset button was basically destroyed.

*My husband has installed all of our radios in every car we've ever owned and in our family and friends vehicles. He's never ran into an issue like this before. We've also never owned a Hyundai before.
 

·
Registered
Joined
·
2,225 Posts
It is possible the speakers are simply no good. Maybe he needs to investigate the speaker end, even if you had a spare speake to connect to the terminals to confirm if the output is arriving there. With heat and age I found 3 of 4 in my Sonata were no good as the foam edges rot away.
 
1 - 2 of 2 Posts
Top