Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
33 Posts
Discussion Starter #1
Twice now the A/C 10 amp fuse under the hood has blown. Once in very hot weather and once today in cooler 77 degree weather. Both times I have been either had my boat hooked up to the vehicle.

First time we had taken the boat to the lake. I knew the air was off because when I went to retrieve the boat, the air was not working.

This time I hooked up the boat to get gas, and when I got back to the garage, the air was not working. I'm not sure exactly when it went out as I had the windows rolled down.

I am wondering if there might be an issue with my light harness to the trailer? Or maybe it is just a coincidence. The boat is only 17' long and well under the towing limit of 3500 pounds. It maybe weighs 2200 trailer and all.

What do you think? I am kind of wondering before I take it to the dealership.

Thanks,

Daniel
 

·
Registered
Joined
·
33 Posts
Discussion Starter #2
Update. Put in a new fuse and it lasted about a minute! Looks like trouble at a higher level.

Off to the dealership tomorrow.

Daniel
 

·
Registered
Joined
·
17,552 Posts
Field coil resistance is likely too high.. current draw across the coil is excessive and making fuse go open on you. Quick check with DVOM tell resistance across coil.

Probably into a compressor replacement.. dont recall if we done coil on the CM model at our place
 

·
Registered
Joined
·
33 Posts
Discussion Starter #4
SBR,

Thanks, took it in this morning and had to make an appointment for Monday.

BTW, my dealership service is very good, and I have a lot of trust in them. Recently the gasket on my timing cover leaked onto the alternator and caused it to go out. They replaced it under warranty.

Daniel
 

·
Registered
Joined
·
1 Posts
i went to replace my front driver side directional bulb in my 09 santa fe but directional still doesn't work. is it a fuse problem? can i just replace the harness if it isn't? what do i do?
 
1 - 6 of 6 Posts
Top