Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
My Tucson 2006, will be ok in idle, i can press the pedal it will be fine 3000 rpm no problem, as soon as I shift gears to D it will die, also on R , In Neutral or park no issues , just when I shift to D, any sugestions, I changed the camshaft sensor, spark plugs and injectors.
 

·
Registered
Joined
·
544 Posts
I would clean throttle body and check that the idle speed controller is working. That compensates for load and allows more air in to increase the idle. SO when you selct a gear it adjusts, same with power steering loads if belt driven and if A/c was turned on, again it would need to throttle up.

If it's idling fine , no load and driving fine, that's what I'd be thinking.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
ok today I invested soime time in the car , this is the current status I ordered the idle control valve since it was cheap, not here yet so I cleanned the trhtle , the car starts fine, I can put in Drive or Reverse it will work great for about 100 Ft after this it will stall, it will start fine but as soon as i get it in drive it dies, also after it stalls the first time the engine will start and it hesitates while I press the accelerator, it will respond but when I start pressing it will kind of try to stall, as soon as it goes into D it will inmkediately die no matter if Im pressing the gas it will just die, I was able to get in in reverse it will stay and even run by itself very slowly, butagain if i press the accelerator it will die, I replaced the camshft sensor spark plugs injectors. the engine sounds fine It has to be something that gets hot and send a bad signal, my guess.

this is the code i get
P0102 CODE DEFINITION:
• Mass Airflow Or Volume Airflow Sensor Circuit Low Input

again any other sugestions very appreciated
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
ok today I invested soime time in the car , this is the current status I ordered the idle control valve since it was cheap, not here yet so I cleanned the trhtle , the car starts fine, I can put in Drive or Reverse it will work great for about 100 Ft after this it will stall, it will start fine but as soon as i get it in drive it dies, also after it stalls the first time the engine will start and it hesitates while I press the accelerator, it will respond but when I start pressing it will kind of try to stall, as soon as it goes into D it will inmkediately die no matter if Im pressing the gas it will just die, I was able to get in in reverse it will stay and even run by itself very slowly, butagain if i press the accelerator it will die, I replaced the camshft sensor spark plugs injectors. the engine sounds fine It has to be something that gets hot and send a bad signal, my guess.

this is the code i get
P0102 CODE DEFINITION:
• Mass Airflow Or Volume Airflow Sensor Circuit Low Input

again any other sugestions very appreciated
• P0102: Mass or Volume Air Flow Sensor "A" Circuit Low
• P0340: Camshaft Position Sensor "A" Circuit Bank 1 or Single Sensor
 
1 - 5 of 5 Posts
Top