Hyundai Forums banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Howdy all, I've gleaned a lot of info from you all over the last couple of years, thanks for it.

My issue for the experts:
2005 xg350L
110,xxx miles
Tach erratic

Tach will at intermittent times go to zero, then rebound. Occasionally will stumble when this happens. No other running issues other than the **** airbag light which I fixed with a piece of black electrical tape (covered the light). Ongoing issue, bothers the wife.

Opinions please?

TIA
Brian
 

·
Registered
Joined
·
24 Posts
My speedometer did exactly the same thing a while back, and that was the transmission output speed sensor, which is an easy fix. Don't know what would make the tachometer do this. But if it is the tach, I'd be tempted to just let it go as I could be happy without a tach at all (but not so for a speedometer).

Dan
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Thanks Dan, the wife has learned to live with black tape over the seat belt light and the check engine light, but the tach bouncing gets her going.

Biggest irritation is that the engine stumbles when it bounces. Did plugs and wires (front 3 plugs were leaking around the ceramic) and hoped I had fixed it. Smoother running but still there just not as much. I suspected the COP but didn't find any evidence of sparking so didn't replace, will now though. All my background says the tach gets its input from the coil but wasn't sure on this setup.

I give the input sensor a serious thought though.

Thanks again
Brian
 
1 - 3 of 3 Posts
Top