Hyundai Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter #1
So I have the common issue of the vehicle not wanting to stay running after filling up with gas. Also, when engine is cold it does the same thing and will die. So I have replaced the purge valve solenoid once and it fixed it. Then it started the same problem again but even worse.

This time it doesn't want to move in drive, I can floor it and it just doesn't have power at all. So I replaced it again and problem fixed. Well that was three days ago and now back to same problem! What could be causing this??

When the engine is cold it feels like it's flooded. Then when I drive it at times has no power and barely wants to go even if I'm flooring it. Then at times it feels fine. It just feels like the engine is always flooded abd can't clear itself out to me.

I smell gas but no leaking anywhere. It's like something is causing it to drain back into the engine idk? My gas mileage has taken a huge hit obviously.

Replacing the purge valve solenoid "fixes" it for a couple days then it goes back to what it was doing. Any ideas or suggestions? I use this car a lot for my jobs so any help is greatly appreciated!!
 

·
Registered
Joined
·
22 Posts
Discussion Starter #7
Clamp off the hose between the purge valve and the intake.

Do I take the hose off from the purge valve and then clamp off? Or just leave it on and clamp it?

Thank you so much! I will do this tmrrw morning and see how it runs tmrrw and post and update.
 
1 - 8 of 8 Posts
Top