Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey folks. Looking for some help with my Terracan. For a while we have had the engine management light coming on when the gear is a little low or high for the speed of the car. We've had it looked at and it came up as sensor issue which was resolved but the light continues to come on. Its not been a major issue and we have just been more sympathetic when driving it to stop the light from coming on. However there has been a development.... I use the terracan to tow my horse which has meant that the light is coming on more frequently and then at the weekend it cut out on my with a shudder and a crunch but started back up fine straight away and allowed me to continue on my way, albeit having to watch out for the light coming on and adjusting my speed/revs accordingly. I love my terracan and I think it has many years of life in it yet so would really like to resolve this issue. The garage has no idea what the problem us and have looked at the most obvious issues. Anyone have any similar experience or anyone able to give me an idea of what the issue is and if it can be resolved?


Thanks
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,318 Posts
Have you had it scanned since the sensor was replaced?
What trouble code is being logged?
 

·
Registered
Drives : Nissan NV200 Flies : Rans S6ES
Joined
·
15,318 Posts
What are you using to scan it?
The CEL is coming on so there really has to be a code logged to explain why.
 
1 - 5 of 5 Posts
Top