Hyundai Forums banner

1 - 4 of 4 Posts

·
Registered
Joined
·
14 Posts
Discussion Starter #1
Hello All,

I am having an issue with the 10amp Tail LP(RH) Fuse. Everytime I start the Car and tun on the lights it blows. I am not sure what to look for. Everything esle works, but there are no dashlights or the interior light inisde the passenger glove box.

Any idea what might cause this?
 

·
Registered
Joined
·
219 Posts
As I am sitting here, I don't know if the front park light, and corner lights are on the same circuit or not. Sooo... remove all the right side bulbs, (not the headlamp) replace the fuse with a new one, and turn on the lights. Is the fuse still good? Now reinstall the bulbs one at a time, and observe if or when the fuse blows. A shorted bulb can still work properly, but still blow the fuse. This is the first check before "ripping into it" Next check is, did someone cob in some trailer wiring at one time? The dash lamp problem may or may not be related. My guess would be not. But possible. Do the bulb checks first.
 

·
Registered
Joined
·
14 Posts
Discussion Starter #3 (Edited)
I drove the car with the burnt out fuse(5 blew) and then decied to try again, its working again. However, I have no clue why 5 blew out.

Currently the fuse is not blowing out and the inboard dashlights are on(as are the lights in the glove box, right tail, and yellow indicater on right side.

The car had no trailer wiring the car was mnie from the dealer.

Where should i check for shorted bulb on right tail or yellow indicator?
 
1 - 4 of 4 Posts
Top