Hyundai Forums banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi everyone,

I seem to have an electrical issue on my 2004 Hyundai Elantra. When I attempt to start the car, at random times I find that all electricity is off, preventing my car from starting. My brakes and steering wheel also seem to lock up when this happens. I have no clue what might be causing the issue or how to fix it.

I had roadside assistance run a diagnostic tonight after being stranded and my battery and starter are completely fine. I thought maybe this would have been caused by my custom stereo possibly draining the battery, but that has been installed in my car since I got it and has never given me any trouble. I've double and triple checked that my subwoofer and amplifier turn off when my car does so they won't drain my battery.

As an example, tonight I unlocked my driver side door manually, then unlocked the other doors with the button on the door. Electricity was fine there since all doors unlocked. However, when I would attempt to start the car, the electricity would be turned off: no dashboard lights, headlights, car locks, etc. One time this happened when I stopped for gas and had to be towed only to find out that my car turned on without problems once it was dropped off at my house!

Can anyone help me out or point me in the right direction of what might be causing this?
 

·
Registered
Joined
·
2 Posts
Discussion Starter #2
Just an update: The issue seemed to be loose battery terminals. I almost wanted to facepalm when the mechanic told me what it was. If anyone else has this issue, save yourself some headache and check on those. It's a simple tightening of a bolt.
 
1 - 3 of 3 Posts
Top