Hyundai Forums banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hello everyone,

My check engine light came on this morning so I went to Auto Zone to have them run a check to see what might be wrong with it. They gave me 3 possible causes that could make the check engine light come on: faulty fuel cap, leakage in emission system, faulty vent solenoid. Could someone tell me how I could find out which of these problems could be happening without spending a lot of money. I'm on disability, so I don't have a lot of money. Maybe also could someone tell me how much something like this costs for each? I checked the cap and it does say on the cap that if it doesn't click 3 times that the light may come on. Since I really know nothing about cars, I thought that I should come here to ask.
 

·
Registered
Joined
·
17,552 Posts
1 - Need engine -- > 2.4, 2.7, 3.5

2 - Need the exact P-xxxx number as stored by PCM and seen on code reader, each number covers a specific area of concern.. lots of evap possibilities, need the code to know which circuit we dealing with.
 

·
Registered
Joined
·
17,552 Posts
0456 is a small EVAP leak.... majority of time it is found to be fuel cap not properly secured...somebody in hurry and just spin cap on, and mot bother to push down and make "click" several times.. Also apply some Vasoline to the rubber ring on the cap, this will allow ring to slide into fill neck a bit easier and seal better.

Other source found has been a leak at the fill vent valve, more so when tank is full, as Hyundai vendor got undercoat on the tank flanges, and then installed parts to the tank,,,, the fuel eats away at the coating, or coating deforms the rubber seal, and leak created.. usually you might smell fuel if lucky.. repair for that has been to remove fuel tank, remove the stuff of the 3 or 4 flanges, clean the under coating off the flange, replace the fill vent valvem re-assemble, then do self test with HI-SCAN.
 

·
Registered
Joined
·
2 Posts
is the crank position sensor the same as the cam position sensor ?? and if not which one is causing my 03 santa fe to stall and not start ???
 

·
Registered
Joined
·
327 Posts
Start another Thread

Ed,
The moderators have placed a good message at the
front end of this forum. You would be well served to
take a look at it and make sure you update your profile
with year, model, engine size, etc. This will allow you
to get help. Also, you should start a new thread and have
it dedicated to your problem.
As for the crank and cam position sensors, they are not
the same. Hard to tell you anything at this point without
knowing which engine. You will also have some error
codes that will most likely tell forum members what your
problem is and they will make recommendations. At
this point, most of them will run past your post unless
you give them enough information to help you.

Welcome and good luck,

Paul
 
1 - 7 of 7 Posts
Top