Hyundai Forums banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
If I'm driving along and I hit the gas to go a little faster occasionally my car will rev like I have it in neutral. I have to pull over, park, and turn it off. When i turn it back on and keep driving it may do it one more time and then it doesn't do it anymore. It feels like something isn't catching when I'm pushing the gas. It's almost as if it's slipped into neutral but the shifter still says drive. Any help or insight would be greatly appreciated!
 

·
Registered
Joined
·
70 Posts
It seems like you transmission is slipping.
How many miles on the car , when was the last time you changed your transmission oil ?

Sent from my GM1915 using Tapatalk
 

·
Registered
Joined
·
3 Posts
Discussion Starter #3
It just rolled over to 100,000 yesterday. It was doing it for a while and stopped for about three months. It just did it again twice today. I haven't changed the transmission oil? I've only had the car since April of last year. It was my sisters before it was mine. I did however check the transmission fluid and it does seem like it has enough.
 

·
Registered
Joined
·
70 Posts
The transmission fluid gets old and needs to be changed at 60k or every few years . You are way overdue. If I were you I would do a drain and fill , driver for 20 miles and do another drain and fill.
Don't do a flush.
A drain usually changes half of the fluid .
So after 2 drain and fills you would be at about 75% new fluid .



hi
 
1 - 5 of 5 Posts
Top