Hyundai Forums banner

1 - 6 of 6 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
The speedometer in my 2002 santa fe stopped working. I have read other forums and they all say to replace the green gear in the transmission speed sensor, but when I took my output speed sensor there was no gear its just a closed sensor. I changed that then I changed the speed sensor on the passenger side axle. and nothing. the cruise control is also not working along with the odometer. has anyone experienced this problem and has the same sensors as I do that can help me fix this?
 

·
Registered
Joined
·
3,038 Posts
The speedometer in my 2002 santa fe stopped working. I have read other forums and they all say to replace the green gear in the transmission speed sensor, but when I took my output speed sensor there was no gear its just a closed sensor. I changed that then I changed the speed sensor on the passenger side axle. and nothing. the cruise control is also not working along with the odometer. has anyone experienced this problem and has the same sensors as I do that can help me fix this?
I believe what you need to change is the VSS (vehicle speed sensor).
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
like i sad in the post, I changed both speed sensors, the one on the wheel and the one on top of the transmission
 

·
Registered
Joined
·
843 Posts
I think you do not quite understand. There are 3 speedsensors on the gearbox!
And there are 4 wheel speedsensors.
On the box there is the input- and output sensor, measuring the speeds of the in and outgoing axle of the box. So giving the function of the gearbox. Further more there is the VSS, vehicle speed sensor, with the mentioned green gear which hooks up internally to the gearbox, which is for your speedo and odo etc.
The wheel speed sensors are for ABS purposes and 4WD activation.
So you probably changed the in- or output sensor, so not the VSS for speedo. The wheel sensor also didn't help of course.
So look for the VSS.
Good luck,
Paul
 

Attachments

·
Registered
Joined
·
843 Posts
Sorry to say I do not know the exact location, I never had to change it myself.
On the electrics schematics it shows somewhere underneath the air cleaner box, which has to be removed for that.
But I think you have to look for the different angle of the connector and follow wiring.
Also you could review older threads about VSS, there are several.
Good luck,
Paul
 
1 - 6 of 6 Posts
Top